Jump to content
UltiMaker Community of 3D Printing Experts

[3.6.0] Anycubic i3 mega doesnt shows material selection tab


dmolpas
 Share

Recommended Posts

Posted · [3.6.0] Anycubic i3 mega doesnt shows material selection tab

Hi, I have just installed cura 3.6.0 and selected my printer  Anycubic i3 mega.


The problem is that no Material tab appears under the printer name so  If you want to set the material proper temperatures you have to go by settings , profile , manage profile , material.

 

menu1.thumb.jpg.e0a86b21fd4d071519717ade9b5f5d75.jpgmenu2.thumb.jpg.9135b348983a30ad4b803e4cfa8f5b0b.jpg
The Menu tab MATERIAL should appear under the printer name above print setup in the right part of the screen just as in any other printer (for example the 4max as i show in the right pic).

Can anyone help me how to mend this ? 

Thank you .

  • Link to post
    Share on other sites

    Posted · [3.6.0] Anycubic i3 mega doesnt shows material selection tab

    Interesting, so it should and does have that feature, just for some reason it's not functional for making G code files for the i3 Mega (newb who just got an Anycubic i3 Mega Ultra base yesterday and have been trying to get Cura to work nicely right from the get go).  But for me, going by settings -> profile -> manage profile -> material doesn't work, it sticks to using what ever Cura is defaulting to for this printer.  I can also hit the custom tab, and even make changes to temperatures there and it still produces G code that does not pay attention to user set temperature settings (haven't played around with other settings - yet).  The only solution I have at the moment is to use notepad and manually edit the resulting G code file to fix bed/extruder temperatures (M104/M109, M140/M190).

  • Link to post
    Share on other sites

    Posted · [3.6.0] Anycubic i3 mega doesnt shows material selection tab

    Sorry, I should report I'm using Cura 3.3.1 from Ubuntu repo's (I normally use Kubuntu) and ended up trying Cura 3.6.0 in Windows 10 on my gaming rig.

  • Link to post
    Share on other sites

    Posted · [3.6.0] Anycubic i3 mega doesnt shows material selection tab

    Well, here's my quick and dirty solution: I added a printer - the Prusa i3 Mk2 - and renamed it to Anycubic i3 Mega Ultrabase.  I then manually copied all the parameters in the Machine Settings from the Anycubic i3 Mega over to the new Anycubic i3 Mega Ultrabase printer.  It now defaults to a print speed of 60mms (instead of the 50mms it was using), but side from that I don't see any drawbacks so far.  But given my newb status, your mileage might vary (I only own 1 printer and only had it for 34 hours and counting).  But Cura now allows me to select the filament type and allows me to adjust temperatures manually via the custom tab.  So I guess that's one quick and dirty solution, but I'm not 100% sure if that's the best solution - so you could try that at your own risk.

  • Link to post
    Share on other sites

    Posted (edited) · [3.6.0] Anycubic i3 mega doesnt shows material selection tab

    Hi !

    The user "SHUMS" from GitHub solved this issue for me i am gonna paste his solution:

    It seems that Cura 3.6 supplied with wrong printer settings.
    For WIN it can be overridden C:\Program Files\Ultimaker Cura 3.6\resources\definitions\anycubic_i3_mega.def.json
    (need administrator rights).

    Change setting "has_materials" from false to true

     

    I used word pad to edit the file and now it shows the materials tab .

    IMG_20181125_132401.thumb.jpg.080efd1ae11911bd7aaa371eddf495df.jpg

     

    Hope it helps you all .

     

    Edited by dmolpas
    typo errata
    • Thanks 2
    Link to post
    Share on other sites

    Posted · [3.6.0] Anycubic i3 mega doesnt shows material selection tab

    In Mac, go to YourMac>YourHardDrive>Applications>Ultimaker Cura.app <right click - show package contents>

    Under Contents>Resources>resources>definitions>anycubic_i3_mega.def.json edit with a non-destructive editor like sublime.app (not text edit).

    On 11/25/2018 at 10:26 PM, dmolpas said:

    Change setting "has_materials" from false to true

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...