Jump to content

Automatic levelling is not working properly / (if at all)


Recommended Posts

Posted · Automatic levelling is not working properly / (if at all)

Hey Forumists,


now I have a complete different problem since a couple of weeks.


1. Tha automatic levelling is not working propperly anmore.


2. I did pretty much all that was recommended in previous forums... Build plate issue, changed nozzeles, updated firmware etc.. nothing works.


3. The cables for the sensor seem to be in place as well


4. can someone check the log-Files to see if the sensors themselves are defective?


Is there some other issue to that?


I would like to attach a video so that you can see what exactly is happening to the system. It also comes to a halt in the middle of the Z-axis, which before it didn´t do... is this supposed to be this way? Then it stops 2-3 cm befor it touches the nozzle (before it stopped ca. 1mm before the nozzle) and it does the ministeps but after a while it just aborts and goes back down telling me to check the nozzles or that the difference between them would be too high. But that is bogus because nothing changed and all the settings remained the samt. It came this way after I updated the firmare of the printer... ah and sometimes it works 1 time out of 15 tries but still the print is not working :-(. The only thing I can do right now is manual levelling but this is a p... !


Please someone from UM3, feel free to post something useful as I can not always do a manual levelling. Before this the prints were smooth and clean. now they are really hard to get them to stick to the bed propperly. I want the automatic levelling to work again.


Thanks for any further advice.







PS: Wanting to show the film I learned that you don´t allow .mp4. Why? Just converting the video did cost me 1 hour of time (onlinconverter) and quality is poor and the video, which was 50MB in .mp4 now has 225 MB in .GiF. I don´t get it... is there an easier way?


PPS: I couldn´t even upload the animated gif now... it is 220MB big the max size you say should be 511MB big and when it´s up after 40 mins. it´s just saying "Upload failed" and it shows an -200 sign in the window. So I´ll just post the issue now without the vid unless you tell me how I get it to be visible...

  • Link to post
    Share on other sites

    Posted · Automatic levelling is not working properly / (if at all)

    Hi Trueblondegod,


    thank you for the post, but I don´t get the same error that you got. With mine it just sais that the printheads are too far of (exeeds limit), but the printbed stops two times (once in the middle before the printheads moove and then before even touching the coretips so there must be somethine else wrong)... I´ld love to show you the vid, but I don´t get to upload .mp4-Files here...


    The second thread was exactly, what I thought too, but the cables are attached to the board so this won´t be the problem either... only if the sensors have a defect. I have a capacitor-meter but I would need some advice on how to read them propperly (e.g. if the machine is runnig, or even doing a leveling test... in this case I would have to dismount them and test them but again this is a moving machine so I would need exact help to be able to execute this kind of a test.) Maybe someone of you already did it and can tell me which contacts to test and what the meter should read at each point.

    That would at least eliminate the problem of not knowing if the sensors would be defective..


    Thanks for any further advice and have a good week.






  • Link to post
    Share on other sites

    • 3 weeks later...
    Posted · Automatic levelling is not working properly / (if at all)

    Hey and greetings again...


    do you have any news regarding the fixing of the automatic levelling problem?


    I still don´t know what exactly is or could be wrong with the UM3... Can I take other steps to eliminate the printbed from stopping half way to the cores and then don´t even touching them? It is pretty sad that I can not use the printer anymore now for almost 3 weeks and there is no clue what I could do to search or narrow in the problem..


    See you and have a nice easter holiday





  • Link to post
    Share on other sites

    Posted · Automatic levelling is not working properly / (if at all)

    I've just gotten done recovering with leveling issues on my UM3, my core findings being this:

    - Glue, even fingerprints on the bed, can affect the leveling results,

    - There are little soft-material covers by the print head. They're not solid, and material can get pushed up behind them. Take your printcores out and give them a thorough inspection, as this can throw leveling,
    - When I added a buildtak flex bed, I didn't realize just how much it would throw leveling, or that it would render auto-leveling useless,
    - Manual level OR auto level, don't expect both to work

    The auto leveling seems to have certain limitations that go out of whack the instant you touch any of the screws. There also seem to be several bugs in the manual leveling process. In order to successfully level my printer, I totally ignored the display and did my own thing, because so many of the prompts were unhelpful (and the lack of a "go back" or "cancel" option is totally frigging annoying with the U3s oops-I-dialed-when-you-clicked dial).


    I would recommend you do a fresh manual level:


    Start by turning all of the screws to make sure they don't feel super loose - don't over-tighten them either. I changed mine from being so lose I could brush one finger tip past and turn them to where I don't need to grip them but I need a fingertip on both sides for them to turn.


    Next, run the manual level and for the "1mm away" step, use something like a credit card. I used an old one and made sure that the raised print fit under the nozzle. No accuracy is really required for this step but I found it helped if all 3 checks were about the same height.


    For the calibration card check: my leveling had resulted in the nozzle being so low that nothing came out. So, I replaced the calibration card with a thin sheet of card, about double+ the thickness of the calibration card. This had several advantages, not least being that its flat without requiring any pressure which might invalidate the calibration.


    When you do this, you're not looking to feel like the card is being caught on the nozzle. You should be sweeping the card/sheet back and forth and then adjusting until you can *just* barely tell that there might be contact with the card.


    I found this so hard to judge that what I actually did was reach the original point I considered "a little resistance" and then give the screw a 1/16th turn in the opposite direction, which put me at a place that ever-so barely felt a little different than moving the card away from the nozzle.


    Then I did a fairly simple test print of a single-layer circular face with a rectangular cut-out in the middle (15mm diameter, 8x5 rectangle).


    I still ultimately wound up making a couple tiny screw adjustments, but I also discovered that running an autolevel after this made things worse again, so I repeated the manual level and I've been getting great prints again. I'm about to apply GR5's tip on setting "Combing Mode" to "not in skin" in the hopes I stop getting horrible, messed up first/top layers.


    • Like 1
    Link to post
    Share on other sites

    Posted · Automatic levelling is not working properly / (if at all)

    Hi kfsone,


    thank you for your exact describtion of things that could help but I think it really is not the printbed or the tip of the nozzles. I already checked if the sensors would be cut of (cable loose) but that doesn´t seem to be the problem.

    The rest is fine.


    I also right now (as I did for the past 3 month) do the manual leveling but that isn´t just as good as it was... as well the prints to get a bit different then they were before.


    Maybe someone can help me with some fotos where to measure the sensors and put the tips of the diode-tester in order to find out if they are still ok and what they should read. That would be a next step.


    As well I have the issue that the printbed stops completely half way up and only then continues the way to the nozzles. The they have 2 choices 1. Then stop 5 mm before they would even touch the nozzles and then return with an error that the differenz bezween the 2 nozzles are too big.. or 2. They touch the printbed and the same error cums up..

    (again: the printbed is perfectly alined.. there is no glue or anything else on the printbed. Just the original glasplate).


    My guess or the sensors are giving out alien signals or the firmware is somewhat corrupted but the latter I don´t think so because it wasn´t becoming any better with an upgrade I did 3 weeks ago...


    Help is still apprecciated...

    Strange wall sideeffects but only on on side.jpg

    Setup UM3ext.jpg

  • Link to post
    Share on other sites

    Posted · Automatic levelling is not working properly / (if at all)

    ... after a firmware reset I still have the trouble but now it is saying (see picture).


    As well the both nozzles were pushed all the way until the end (so far that even the printbed did distort itself a bit). I really believe now that the both sensors are gone with the wind...


    I need a way of testing them..

    Prabbably sensors.jpg

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...