Jump to content

Cannot Run Cura 4.0 on XPS 13


Recommended Posts

Posted · Cannot Run Cura 4.0 on XPS 13

Hey everyone. Recently, as a part of my move to a college laptop, I installed Cura, having used it flawlessly for years on my desktop, including version 4.0. However, I haven't even been able to open the program. I have tried pretty much everything (uninstalls, installing version 3.6, clearing out all files manually) including running DDU on my nvidia driver as recommended by a reddit user, given the possibility that having both an intel iGPU driver and an nvidia desktop GPU driver could pose (I am using a Razer Core V2 as a part of my computing solution). Does anyone have any idea how to go about fixing this? I REALLY don't want to lose all of my configuration files that I have created over the years, nor do I want to learn a new program. Thanks!


Just an FYI: I tried to find the log files and they don't seem to exist, it seems like the program isn't even getting far enough to generate a log.

  • Link to post
    Share on other sites

    Guest jerooney1
    Posted · Cannot Run Cura 4.0 on XPS 13

    Hi F,


    Don't worry, as long as you're still able to access your old desktop computer, you will be able to backup your profiles!

    For your initial issue:
    - Have you tried running the software without the Razer Core V2, running on the internal GPU only?

    - Could you share a DXDIAG report?
    - Have you checked both:

    • Computer/users/[user_name]/AppData/Local/cura
    • Computer/users/[user_name]/AppData/Roaming/cura

    If you would be able to find log files, that would really help the troubleshooting.





  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 2 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
          • Like
        • 26 replies
    • Create New...