Jump to content
bitboy

Ender 3 Pro + Silent Board + Pause at height

Recommended Posts

Posted · Ender 3 Pro + Silent Board + Pause at height

Hallo zusammen,

 

Ich versuche die Funktion Pause at height zu nutzen um 2 farbig zu drucken. Leider wird das noch nicht wirklich was.

Die Pause wird richtig gesetzt, ich wechsel das Filament und schiebe soweit durch bis die Farbe sauber rauskommt.

Bei resume print extrudiert der Drucker nun allerdings abermals und schmiert das ganze dann über den schon gedruckten Teil.

Das Plugin zum Filament wechsel kann ich leider nicht benutzten, da die Stock Firmware vom Silentboard das Kommando M600 nicht unterstützt.

Cura Version ist 4.4.0

 

Hätte hier jemand einen Tipp?

 

Ich hab mal den gCode angehangen den das Plugin bei mir produziert.

Einstellungen:

Layer: 12

x, y: 20

Retraction: 300 (das filament soll ausgeworfen werden)

Retraction speed: 25

Extrude amount: 0

Extrude speed: 3.333

Redo Layers:0

Standby Temp: 200 (Ich sitz daneben kann also sofort wechseln)

 

Seltsam scheinen mir die Anweiseungen G1 F1500 E300 E-300 E300 zu sein.

Damit der Stepper deaktiviert wird fürge ich vor M0 noch M18 E ein und danach zum aktivieren M17 E.

;script: PauseAtHeight.py
;current layer: 12
M83 ; switch to relative E values for any needed retraction
G1 F1500 E-300
G1 F300 Z2.56 ; move up a millimeter to get out of the way
G1 F9000 X20 Y20
G1 F300 Z15 ; too close to bed--move to at least 15mm
M104 S200 ; standby temperature
M0 ; Do the actual pause
M109 S200 ; resume temperature
G1 F1500 E300
G1 F1500 E-300
G1 F300 Z2.56
G1 F9000 X112.905 Y123.306
G1 F300 Z1.56 ; move back down to resume height
G1 F1500 E300
G1 F1500 ; restore extrusion feedrate
M82 ; switch back to absolute E values
G92 E999.59351
;LAYER:12

 

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height
14 hours ago, bitboy said:

Bei resume print extrudiert der Drucker nun allerdings abermals und schmiert das ganze dann über den schon gedruckten Teil.

 

Ja, das ist wohl so gedacht. Wenn für die Pause ein Wert bei "Retraction" eingetragen ist, wird der gleiche Betrag beim "Resume" auch wieder vorgeschoben (ggf. zuzüglich dem "Extrude amount"). Das Postprocessing-Skript kann ja nicht wissen, das Du das von Hand machst.... 🙂

Als "Retraction" sind auch eher ein  paar wenige mm vorgesehen, damit während der Pause nicht so viel heraustropft. Zum Auswerfen des gesamten Materials ist das ganz sicher nicht gedacht...

 

Aber wenn Du eh' schon dabei bist, den gcode manuell zu ändern, dann nimm die drei fraglichen Zeilen doch einfach raus.

Oder Du lässt den Wert für "Retraction" auf Null stehen und ziehst das Material auch manuell heraus, dann passt es auch wieder.

Oder Du fügst nur die Zeile zum Auswerfen des Materials nachträglich manuell ein.

Oder Du machst eine Kopie vom Postprocessing-Skript, gibst der Kopie einen neuen "name" und "key" - und änderst es gleich dort - das Skript ist ziemlich gut kommentiert (lohnt sich aber wahrscheinlich nur, wenn Du das öfter brauchst).

 

 

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height

Hi, danke für die antwort. Bin ja erst nen Monat mit 3D Druck zugange und weils bei anderen funktioniert dachte ich, ich mach was falsch. Schöner wärs natürlich wenns vorgefertigt mit plugin funktioniert statt manuell.

Dass die retraction nach der Pause automatisch rückgängig gemacht wird ergibt sich leider nicht aus den Infoboxen der Plugin, daher ist das Verhalten eher unerwartet, besonders da es noch eine eigene Einstellung für Extrude gibt.

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height
43 minutes ago, bitboy said:

Dass die retraction nach der Pause automatisch rückgängig gemacht wird ergibt sich leider nicht aus den Infoboxen der Plugin, daher ist das Verhalten eher unerwartet, besonders da es noch eine eigene Einstellung für Extrude gibt.

 

Klar, die Frage ist durchaus berechtigt. Spätestens wenn man das Pause-Skript für Zusatzarbeiten "missbrauchen" muss, sind die Beschreibungen definitiv nicht ausreichend!  😁

Chep zieht das Filament doch auch einfach per Hand raus (im Video), das wäre die einfachste Methode.

 

Schade ist nur, das der Drucker für den Filamentwechsel keine Unterstützung hat. Zumal die Marlin-Firmware das alles schon bietet, es muss halt nur vom Hersteller aktiviert werden.

 

Nur aus Neugier:

Der Ender 3 hat doch einen Filament-Sensor und geht automatisch in den Pause-Modus, wenn das Material zu Ende geht, oder? Wie soll denn dann der Wechsel auf eine neue Rolle stattfinden?

 

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height

Hi, ich hab ehrlich gesagt keine Ahnung wie der Kollege einfach das Filament rauszieht. In meinem Gerät kann man das Filament jedenfalls nicht rausziehen ohne dass sich der Stepper dreht, heißt der muss disabled sein. Zum reinschieben kurbel ich an dem Drehrad weil einfach reindrücken geht auch nicht.

Ergebnis ist: Meistens verschieb ich die Z Achse weil der Z-Stepper aus noch unbekanntem Grund mit deaktiviert (Timeout? Default von M0?) wird. Dann is der Print natürlich hin.

Der Ender 3 oder auch der pro hat default kein Filament Sensor, es gibt welche die rüsten das nach. Hab auch diverse Videos dazu gesehen und sieht da ähnlich einfach aus wie in dem gezeigten.

 

Das Standardboard hat wohl auch die advanced_pause M600 aktiviert, nur das Silent Board nicht (hab ich gelesen).

 

Daher auch die Frage hier. Was der Typ im Video macht sieht extrem simple aus, klappt bei mir aber praktisch gar nicht.

Und zur Ergänzung: Ich nutze Cura auf Linux, da gibts das nur als "appimage" ist also eine kompakte Datei das Programm. Das pause script umzuprogrammieren fällt daher auch wohl eher flach.

 

Von daher fummel ich manuell am gcode und such ne Variante die den Z Stepper eingeschaltet lässt damit die Achse nicht so leicht verschoben werden kann, den E ausschaltet, das Filament zumindest ein Stück aus dem Hotend rauszieht und hinterher nicht auf gut Glück wieder rausschiebt.

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height
2 hours ago, bitboy said:

Meistens verschieb ich die Z Achse weil der Z-Stepper aus noch unbekanntem Grund mit deaktiviert (Timeout? Default von M0?) wird.

 

Es gibt in Marlin sowas: "stepper inactivity timeout", das kann mit "M18 S0" deaktiviert werden, dann gehen die Motoren nicht mehr von selbst aus.

 

2 hours ago, bitboy said:

Ich nutze Cura auf Linux, da gibts das nur als "appimage" ist also eine kompakte Datei das Programm. Das pause script umzuprogrammieren fällt daher auch wohl eher flach.

 

Für den Fall, das Deine Ambitionen soweit gehen:

Eigene Skripte können auch im Cura-Konfigurations-Verzeichnis abgelegt werden (in Cura " Help -> Show settings folder" - im Unterverzeichnis "scripts").

Die mitgelieferten Skripte sind auch auf Github zu finden, dann musst Du nicht das AppImage mounten:

https://github.com/Ultimaker/Cura/blob/master/plugins/PostProcessingPlugin/scripts/PauseAtHeight.py

 

Ich hab das noch nicht gemacht, aber vermutlich ist es sinnvoll (notwendig?), name und key (in Zeile 17-18) auf eigene Bezeichnungen zu ändern, dann sollte Cura das kopierte Skript mit dem neuen Namen auch anzeigen. Falls nicht: Fehler werden in cura.log protokolliert.

Share this post


Link to post
Share on other sites
Posted (edited) · Ender 3 Pro + Silent Board + Pause at height

Ahh vielen Dank, das hilft auf jeden Fall schonmal weiter.

M18 S0 hatte ich zwischenzeitlich auch entdeckt, hat aber nicht geklappt. M18 S999 schon, allerdings waren dann auch alle Stepper eingeschaltet, selbst dann wenn ein M18 E folgt. hm blöd.

Dafür kann ein G28 Z helfen wenn man doch aus versehen die Z Achse verschiebt, genügend Platz vorausgesetzt, wird die Achse damit einfach nochmal auf den Nullpunkt gefahren sodass folgende Höhenangaben wieder stimmen. Das schon gedruckte darf halt nicht im Weg von dem waagerechten Rahmenteil sein.

 

Mit Kraft geht das Filament schon raus auch ohne den Stepper zu drehen. Ich versuchs mal weiter, ein eigenes Pause script für den Ender + SilentBoard könnt sich vllt lohnen da andere anscheinend auch Schwierigkeiten haben. Mal sehen. Hier mal der vorläufige gcode

 

;script: PauseAtHeight.py
;current layer: 3
M83 ; switch to relative E values for any needed retraction
G1 F1500 E-30 ;retract 30mm
G1 F300 Z1.48 ; move up a millimeter to get out of the way
G1 F9000 X20 Y20
G1 F300 Z15 ; too close to bed--move to at least 15mm
M104 S200 ; standby temperature
M18 S999 ; disable stepper timeout -> steppers keep enabled
M18 E ; disable stepper E ; not working :(
M0 ; Do the actual pause
G28 Z ; optional: home Z again
M109 S200 ; resume temperature
G1 F300 Z1.48
G1 F9000 X125.977 Y98.291
G1 F300 Z0.48 ; move back down to resume height
G1 F1500 ; restore extrusion feedrate
M82 ; switch back to absolute E values

 

Edited by bitboy

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height
1 hour ago, bitboy said:

allerdings waren dann auch alle Stepper eingeschaltet, selbst dann wenn ein M18 E folgt

 

Nach ein wenig suchen: das scheint ein "Feature" von den Creality-Boards zu sein, X,Y und E lassen sich nur gemeinsam ein- und ausschalten. Nur der Z-Motor hat einen eigenen "enable pin".

"M18 X" würde also auch den E-Motor abschalten, aber dann sind X und Y halt auch aus... - kein Glück damit also.

 

Schöne Bescherung! 🎅

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height

Hättest du da einen Link?

X Y E disabled wäre auch noch akzeptabel, Hauptsache der Z rutscht nicht davon.

wenn von pin enabled die rede ist klingt das als wärs aufm board fest verdrahtet. Nächste Frage gilts auch für das relativ neue silent Board?

 

Ich hab mir die Scriptsache mal kurz angesehen.

Der Dateiname, der Klassenname und der Key müssen scheinbar identisch sein damits richtig erkannt wird.

Wenns dann noch Probleme gibt stehts in der Logdatei

 

Immerhin hab ich mit der Modifikation oben schonmal ein brauchbares Ergebnis bekommen 🙂

 

*plätzchen und kekse smiley*

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height
50 minutes ago, bitboy said:

Hättest du da einen Link?

 

Naja, Vorsicht - mein Ansatz ist ein bisschen "nerdy", die Erkenntnisse passen aber zu den Symptomen 😁

 

Als Quelle für die Ender-3 Firmware hab ich nur das hier gefunden:

 

https://github.com/Creality3DPrinting/Ender-3

 

Wenn man sich ein bisschen durch die Pin-Definitionen für "MELZI_CREALITY" hangelt, landet man irgendwann hier:

 

https://github.com/Creality3DPrinting/Ender-3/blob/master/Ender-3 Firmware (Marlin)/Ender-3 (includes power failure resume- English)/Marlin/pins_SANGUINOLOLU_11.h#L99

 

...und diese Pin-Definitionen führen dann dazu, das "M18 E" von der Firmware ignoriert wird:

 

https://github.com/Creality3DPrinting/Ender-3/blob/master/Ender-3 Firmware (Marlin)/Ender-3 (includes power failure resume- English)/Marlin/Marlin_main.cpp#L8105

 

Was da auf den neuen Boards vorinstalliert ist, weiß ich aber natürlich auch nich...

Bis auf die TMC Treiber-Chips scheint sich die Hardware aber kaum zu unterscheiden (sagen die Youtube-Kommentare... 😏)

 

Viel Spaß noch damit!

 

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height

Respekt wie schnell du das gefunden hast... Aber ja ergibt Sinn irgendwie. Das im Repository ist aber nicht exakt die Firmware die ich hab, im Repro is das advanced pause aktiviert, bei den silent boards anscheinend nicht 😕

 

Hab jedenfalls mal mein eigenes pause Script hingebastelt, damit sollte es dann auch einigermaßen funktionieren.

https://github.com/bitboy85/PauseForFilamentChange

 

Danke für die Unterstützung 🙂

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height

Was ist eigentlich mit der TH3D-Firmware? Wenn das Board einen Bootloader installiert hat, könntest Du diese einfach mal testen. Die vorinstallierte Firmware ist dann allerdings weg... 🤷‍♂️

 

http://firmware.th3dstudio.com/

 

Das scheint ziemlich gut dokumentiert zu sein und ist in der Creality-Gemeinde sehr beliebt (und ADVANCED_PAUSE_FEATURE ist standardmäßig aktiviert).

Share this post


Link to post
Share on other sites
Posted · Ender 3 Pro + Silent Board + Pause at height

Auf lange Sicht werde ich mich bestimmt mit anderer Firmware beschäftigen. Meistens versuch ich aber erstmal mit Stockfirmware klar zu kommen, dann ist die Lernkurve auch nicht ganz so steil.

 

Bootloader soll bei dem Silent Board vorinstalliert sein.

Ich frag mich halt ob es einen Grund gibt, das dieses Feature per Default aus ist, bei den nicht-silent Boards ist es nämlich an und dazu hab ich noch keine Info.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!