Jump to content
heqe95

Inner wall not generated on topmost layers.

Recommended Posts

Posted (edited) · Inner wall not generated on topmost layers.

A very minor issue in Cura 4.5, but one that I haven't seen before just like this.
 

Inner wall is not generated, in my case, for the topmost 6 layers. It is generated fine on other layers that have exactly same width features. Somehow it ceases existing when another feature in the layer ends.In picture, lowest layer has 3 parallel lines, topmost layers only 2. This is enough to cause a visible 0.25mm gap in the final print. This "bug" happens also elsewhere in the print.

 

1968684035_gapinwall.thumb.JPG.32ee8ba68848ab75e4777a487617f8a0.JPG

 

The following settings have no effect:

-Print thin walls.

-Top Layers/Top surface skin.

-Fill gaps between walls.

-Compensate Wall overlaps.

 

Only way to solve this is to try to manually find suitable Line Width -settings for your print so that there are no visible gaps present. Of course this is not optimal.

 

So pretty minor issue and there is a workaround but want to report this as I have high standards for my overall best slicer.
 

This issue is similar, but not quite:


------------------------------

Edited by heqe95

Share this post


Link to post
Share on other sites
Posted · Inner wall not generated on topmost layers.

It's a bug in the current way that walls work. It is kind of inherent to how walls should be generated. Walls should be generated on all sides of a print, so also both sides of your thin region. That means that across that thin region it will always generate an even number of walls. If you model a part to be exactly as wide as 3x the line width then depending on which way the rounding goes it will either fill using 4 lines or using 2 lines (and fill up the remaining space using a single line, if Fill Gaps Between Walls is enabled).

 

We're currently working on a fix, but it is rather complex, so it might take a few months before it becomes available in Cura.

 

Meanwhile: try adjusting your part or adjusting the wall line width or enable Fill Gaps Between Walls.

Share this post


Link to post
Share on other sites
Posted · Inner wall not generated on topmost layers.

Thanks for answering and good luck fixing it.

Fill gaps between walls seems like the feature that should be fixing this, but it doesn't do it consistently and everywhere.

One thing I noticed, is that the problem goes away if I use a non-zero infill. I was trying to print walls only, but 0.01% infill is the new 0% I guess! 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Survey: Understanding your workflow
      Interact with future concepts and aim to collect your feedback and opinion. In particular, if this would/could be a welcome addition to your 3D printing workflow. Interested?
      • 0 replies
    • Coronavirus: Let's do our part
      Through this post I would like to further explain what we are doing, and what you could be doing. 
      Our efforts consist of 2 layers. First; connect medical institutions and hospitals to (local) 3D Printing hubs to help them print parts of which a 3D model already exists. And second, contribute to design the necessary part and then have it printed via a (local) 3D printing hub. Experts are available from within Ultimaker and from within our network of 3D printing experts.
        • Like
      • 53 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!