Jump to content
Ultimaker Community of 3D Printing Experts

S5 Firmware Update Errors (5.3.10.xx)


joltdad
 Share

Recommended Posts

Posted · S5 Firmware Update Errors (5.3.10.xx)

I unpacked an S5 yesterday and saw that the firmware was out of date (5.3.10.20200107) vs the most current version (5.5.12). I tried to update the software using a USB key as described on the Ultimaker S5 help page  but the update process was unsuccessful - after restarting, the printer displays an error message that the software installation was unsuccessful, and suggests a power cycle. I don't get any specific error code. I've tried three different downloads and thumb drives, including the one shipped with the unit.

 

When I try and install the software update on the device itself, I see a blank screen after tapping the "software version" button, and have no option to upgrade.

 

In the web interface, the most recent software version is listed as "0.0.0.0" and I therefore have no option to upgrade:

 

image.png.e28c65c4bb43a37364726a0094abe330.png

 

Is this a known error? What steps can I do to upgrade my unit?

 

Thanks!

 
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...