Jump to content
Ultimaker Community of 3D Printing Experts

Stop Cura (4.4 & 4.5) lowering the nozzle before printing.


Darren_Lines
 Share

Recommended Posts

Posted (edited) · Stop Cura (4.4 & 4.5) lowering the nozzle before printing.

Hi guys,

 

Since Cura 4.4, some G-code is added somewhere that lowers the nozzle before going to the start point of the print job. Cura 4.3 and previous did not do this.

 

Does anyone know where this code is added so that I can remove it. The issue is that on some jobs, lowering the nozzle before getting to the start point will hit my nozzle in to the crocodile clips that hold the glass bed in place. I guess this is an oversight as the coders think that everyone is using magnetic beds now?

 

I know that it's not in the printer or extruder G-code in the machine settings. This is added after that. Any help to fix this bug would be greatly appreciated.

Edited by Darren_Lines
  • Link to post
    Share on other sites

    Posted · Stop Cura (4.4 & 4.5) lowering the nozzle before printing.

    No problem. The Start G-code I currently have in the printer machine settings is

     

    M117 Initialising...
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 X0 Y0 ;move X/Y to min endstops
    G28 Z0 ;move Z to min endstops
    G92 E0 ;zero the extruded length
    M117 Cleaning... ;Put cleaning message on screen
    ; - reposition nozzle
    G1 Y10 Z5 F10000 ;raise nozzle 5mm and move along Y by 10mm
    ; - continue cleaning
    G1 Z1 ;Move nozzle close to the bed
    G1 E10 ;extrude 10mm of filament
    G1 Z15 F15000 E5 ;Move up 15mm fast, while extruding 5mm
    G92 E0 ;zero the extruded length again
    G1 X0 Y0 ;home the nozzle
    M117 Printing...

    I have changed this to move the cleaning operation so that the cleaned nozzle didn't lower its self back in to the extruded filament. The lowering happens after the G1 X0 Y0 command at the end.

    Visor_NHS.3mf

  • Link to post
    Share on other sites

    Posted · Stop Cura (4.4 & 4.5) lowering the nozzle before printing.

    Hi, sorry for the slow response, it's been a busy day. So, I think this behaviour has been introduced by a recent revamp of the retraction/z-hop code. Arguably, it's a regression. The only workaround I can suggest is to turn off z-hop. For this particular print, that's of no consequence (I think) because it doesn't appear to do any other z-hops in the print. I recommend you open an issue at the cura github as this should get a proper fix.

     

    • Thanks 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...