Jump to content
Sign in to follow this  
woutzweers

calibrating x, y

Recommended Posts

Posted · calibrating x, y

My ultimaker is just off the accurate calibration. 97 mm prints as 99 mm.

anybody who can explain how to calibrate the steppers?

tnx

wout

Share this post


Link to post
Share on other sites
Posted · calibrating x, y

Steppers don't need calibration. They always do 200 steps per rotation. The rest is all fixed mechanical. Resulting in the right number of steps per mm of movement.

But... are you printing with PLA or ABS? ABS shrinks, so that would explain the 2mm difference. PLA also shrinks a bit, but only a tiny bit compared to ABS.

Other causes for smaller objects could be wrong slicing configuration settings.

Share this post


Link to post
Share on other sites
Posted · calibrating x, y

tnx for the answer

i'm working with pla

i wonder what could be wrong with the slicing

any suggestion?

(i'm using skeinforge)

Share this post


Link to post
Share on other sites
Posted · calibrating x, y

Well, now that your printer is working, it's recommended to upgrade to Marlin to start with, gives much better prints.

The Beta3 from SkeinPyPy:

https://github.com/daid/SkeinPyPy/downloads

assists you in upgrading to Marlin, and also contains an easier configurable Skeinforge.

Not sure what could be wrong with your Skeinforge settings, but I made this display frame, sliced with SkeinPyPy. And it was spot on size wise. The hole for the display was exactly as the measured size of the display itself. It wouldn't have fit if it had become 2mm smaller.

Share this post


Link to post
Share on other sites
Posted · calibrating x, y

You might be using an old firmware from prior to October 2011.

The correct 1/16 steps per mm is 78.7402

if you get the current Marlin installed, the value is set correctly:

#define DEFAULT_AXIS_STEPS_PER_UNIT {78.7402,78.7402,200*8/3,865.888}

alternatively, you can add the following line in the beginning of your gcode:

M92 X78.7402 Y78.7402

That should make 100mm 100mm... at least on my UM... if that is not solving the issue, you might want to look into loose belt issues, if there is too much or any slack, the precision goes down.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 20 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!