Jump to content
Ultimaker Community of 3D Printing Experts

Brand new Ultimaker 2+ not starting.


Ow8
 Share

Recommended Posts

Posted · Brand new Ultimaker 2+ not starting.

I recently purchased an Ultimaker 2+ and when I plugged it in for the first time, the blue light for the power box came on but when i conected the box to the printer the blue light wenr off and nothing happened to the printer??!. After unplugging and switching on/ off multiple times still nothing happened. Please help!!  

  • Link to post
    Share on other sites

    Posted · Brand new Ultimaker 2+ not starting.

    Maybe a short circuit or a defect of the power brick.

    I am afraid but I think we cannot help you much with this issue. I would return it if you just have purchased the printer.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...