Jump to content

Pause at Height Fix


funx

Recommended Posts

Posted · Pause at Height Fix

I recently installed a silent motherboard for my Ender 3 Pro only to realize that it no longer stayed paused with the standard M0 command. Does anyone know what might be the cause for this?

 

After some tinkering, I discovered that it worked when given the expire time parameter (ex. M0 S120). I made a modified version of the Pause at Height script that allows you to specify the expire time and thought I'd share it in case anyone else was experiencing the same issue.

PauseAtHeight2.zip

  • Like 1
Link to post
Share on other sites

Posted · Pause at Height Fix

Another issue that I'm running into is a blob on the print after resuming from a pause. I think I have diagnosed the issue. Here is a sample of g-code from a print with the pause-blob:

 

Just before the pause:

 

G1 F1800 X94.951 Y119.841 E334.40799
G1 F3000 E327.90799
;MESH:NONMESH
G0 F300 X94.951 Y119.841 Z0.8
G0 F9000 X98.742 Y100.597
;TIME_ELAPSED:425.699921
;TYPE:CUSTOM
;added code by post processing
;script: PauseAtHeight.py
;current layer: 3
M83 ; switch to relative E values for any needed retraction

 

Note that the two G1 lines indicate a retraction of 6.5mm, which is what I have set as my retraction distance in the slicer settings.

 

Here's the very end of the pause:

M82 ; switch back to absolute E values
G92 E327.90799
;LAYER:3
M117 Layer 3 of 5 CE3PRO_mgschip_test
M106 S153
;TYPE:WALL-INNER
;MESH:mgschip_test.stl
G1 F3000 E334.40799`

 

The G92 line is using the retracted value. The printer does not realize this and does an extrude right onto the print.

 

Perhaps there is a way the script could compare the two most recent absolute E positions and use the larger of the two?

  • Link to post
    Share on other sites

    Posted · Pause at Height Fix

    I have the 1.1.5 board in my E3Pro with Marlin 1.1.8 and the "M0" works (the board is about 9 months old).  I have heard of this problem with the newer ones.  Sounds like a good fix.

    I use PauseAtHeight a lot for color changes.  No retraction and no extrude have worked the best for me.  I just shove the new filament in until the color changes, grab the booger with long nose tweezers, and hold it steady while I hit the button.  The best thing is to have the re-start within support or infill but you don't always get a choice.  I've had good success though with my "snatch-grab-hitthebuttonreallyfast" method.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...