Jump to content

Buggy G-Code Files? - solved

Recommended Posts

Posted · Buggy G-Code Files? - solved

Since Cura 13.10, when exporting G-Code files and printing them on my Ultimaker 2 via SD Card, the files seem to be buggy. The print head immediately starts to print in mid-air, without raising the build platform and without heating the head.

The temperature shows "22/0 °C".

Here's one of the generated G-Code files, if someone wants to analyze it: http://tmp.dbrgn.ch/bearing6.gcode

I'm using Arch Linux with the package from AUR: https://aur.archlinux.org/packages/cura/ (see https://aur.archlinux.org/packages/cu/cura/PKGBUILD)


Share this post

Link to post
Share on other sites
Posted · Buggy G-Code Files? - solved

What version of the firmware are you running on your printer?

It seems that perhaps the printer isn't recognizing it as an UltiGcode file, and so expects the file to include all of the preamble to heat the bed etc. However, the file looks perfectly normal to me.

So how do you print, since Cura messes up like this?


Share this post

Link to post
Share on other sites
Posted · Buggy G-Code Files? - solved

I simply downgraded to an older version. 13.06.5 seems to work fine.

You might be right about the UltiGcode thing. In contrast to the older version, in the newer version this whole part is missing from the preamble:


G21 ;metric values
G90 ;absolute positioning
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 Z15.0 F9000 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000
M117 Printing...

I last upgraded the firmware about half a year ago. I guess I'll have to do that again, to be compatible with the newer version...


Share this post

Link to post
Share on other sites
Posted · Buggy G-Code Files? - solved

I'm confused.

You can't have had an Ultimaker 2 for 'half a year'. They didn't start shipping until the end of October.

If you have an original Ultimaker, then you can't use 'Ultigcode', you have to configure Cura for an Ultimaker Original, with Reprap/Marlin gcode. That expects there to be the preamble gcode that you quoted above to set the temps, home the head, etc. Even with the most recent firmware, it won't work right with Ultigcode, currently.

On an Ultimaker 2, you don't need to do those things if the file is marked as 'Ultigcode' - the UM2 firmware provides the necessary homing and warm-up operations automatically.


Share this post

Link to post
Share on other sites
Posted · Buggy G-Code Files? - solved

Oops, sorry. It's an Ultimaker 1 of course. The wooden one. I somehow mixed it up :)

Thanks for the help.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • January 22nd  | Ultimaker webinar 'Learn how to choose the right composite material'
      We’ll teach you how to choose the right composite material for your application in our new 40-minute webinar. You will learn how to: 
      • Make the perfect choice between glass and carbon fiber 
      • Identify more high-value applications that would benefit from composites 
      • 3D print advanced materials with the right settings 
      • Select the best materials for 3D printing end-use parts 
      • Use dual extrusion to take composite 3D printing to the next level 
      • 0 replies
    • Does your company use Ultimaker? Know one that does? Let us know!
      If your company uses Ultimaker in any capacity, we'd love to hear about it! If the story is there, and you're up for it, maybe we can work together to create a story that will be featured on the site. Here are examples of..
      • 18 replies
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!