Jump to content

Cura hangs constantly to the point of being unusable


halr9000

Recommended Posts

Posted (edited) · Cura hangs constantly to the point of being unusable

I've researched this multiple times and seen other reports going back at least a couple of years across many versions, bottom of this post are a couple of examples. Whatever problem I'm having, I can reproduce it across all of those versions. 

 

Symptom: app hangs very frequently, often multiple times per minute, but sometimes less often and I can start to get some jobs going. As a sample of what this looks like, here I am simply switching tabs in the settings, and it hangs halfway while drawing the screen, often sitting here for 10's of seconds.

image.thumb.png.68c3b3290d614ddf333a8fc1bbc05994.png

 

 

 

I had not looked at the logs before this moment but have attached %appdata%\cura\stderr below.

 

Have attempted to uninstall and reinstall (and different versions). I think I've tried it with a clean profile, but I know I have tried it w/o using my ultimaker cloud backup. I suspect something in my profile is causing the issue, but it's not clear at all how to determine what, if anything is causing the hangs, or what I can do about that.

 

Perhaps someone more familiar with the logs can have a look? TIA

 

 

 

stderr.log

cura.log DxDiag.log

Edited by halr9000
added more log files & screenshots
  • Link to post
    Share on other sites

    • 3 months later...
    Posted · Cura hangs constantly to the point of being unusable

    I'm kinda amazed that nobody else is seeing or complaining about this. Just reinstalled Cura to see how things have progressed since the beta. Performance was great and I was optimistic. My profile had 2 plugins only, so I reinstalled the 1 additional I really needed (snapmaker). Still good, so I did my thing. Came back today to browse the marketplace and re-add some previously used plugins and...performance and the lag comes back. So it's good to know that it's caused by 1 or more plugin anyway.

     

    I'm going to turn them all back off in the meantime, but as the lag is so severe, it makes troubleshooting all but impossible in the GUI. Does anyone know how to isolate which plugin it is which is causing my issues? I may look myself later, but any tips on enabling/disabling plugins by config file would also be helpful. TIA.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...