Jump to content
Ultimaker Community of 3D Printing Experts

Cura 5.0.0 fails to start on Mac Monterey 12.4


Recommended Posts

Posted · Cura 5.0.0 fails to start on Mac Monterey 12.4

Hi all, I hope I can get some help. 

I use a 2018 Macbook Pro that is running Monterey 12.4 and I've just installed Cura 5.0.0

 

When launching it, it runs through the splash screen, but never actually opens. Just sits there as an icon on my taskbar showing it's open, but I never get any further. 

I've tried searching this site, and Googling, but can't find an answer. 

Previous versions of Cura work fine, but not 5.0.0

Thanks very much in advance for any help.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 12 replies
    ×
    ×
    • Create New...