Jump to content

Cura 5.3 Printer definition file in user configuration folder not being read (wrong mesh used)


ksihota
Go to solution Solved by Cuq,

Recommended Posts

Posted · Cura 5.3 Printer definition file in user configuration folder not being read (wrong mesh used)

A few years ago before I got my first AnyCubic Predator I decided to try my hand at building a printer definition setup for use in Cura since one did not yet exist. I put it together and tested it out once I got my printer. When I knew it was working I posted the files and the instructions on how set it up inside the Cura configuration folder (it is on Thingiverse) since I was not yet prepared to submit it to Cura for inclusion in the stock download.

It worked fine and upgraded properly with new versions of Cura. At one point another user asked if they could submit it to Cura and I agreed. They submitted it, but had to change the mesh obj file to a stl because my original obj file was too large.

Although this did change the display slightly (no image template) it was not an issue since whenever Cura upgraded it would first read the resources printer.def.json file but after a restart or the user configuration file was touched Cura would then read the local printer.def.json file (user configuration folder) where my original obj file and png template files were referenced and they would then display properly.

At one point in the upgrades (around V4) Cura set some kind of file size limit on the mesh size so mine would no longer work. At that point I rebuilt my obj mesh and shrunk the size considerably (well within limits) and my mesh displayed properly again.

 

The latest issue I have been having, which may have started with v5 of Cura, is that the printer.def.json file in the Cura resources folder appears to be the only one that is being read.

I have tried restarting Cura and changing settings in Cura in order to force the program to see my local printer.def.json file but nothing seems to work. The only way I have been able to get my mesh to work properly is to edit the Cura version of the printer.def.json file and specify the mesh obj fle instead of the current mesh stl file. At that point Cura will then look in my local configuration meshes folder and use the proper file.

So obviously Cura is still reading the local configuration folder since it is able to read the local mesh obj file but it does not appear to be reading the local printer.def.json file that included the proper mesh file reference to begin with.

 

Was there some change in Cura 5 that I need to account for, to ensure that Cura will read the local printer.def.json file, so I do not need to manually change the Cura file each time I upgrade Cura?
Is there anything else I have overlooked that might be causing this issue?

 

Thanks for any assistance anyone can provide.

  • Link to post
    Share on other sites

    Posted (edited) · Cura 5.3 Printer definition file in user configuration folder not being read (wrong mesh used)

    Don't really understand why you not simply create your own predator.def.json file in your local user definition folder as it should be and not try to mess the configuration by duplicating the files in your local configuration. With a unique name you will be sure to avoid all the problem. I m working like that and doesn't have any issue from 4. To 5.3 (except with the issue of this 5.3 alpha sharing the same folder as the 5.3 )

    Edited by Cuq
  • Link to post
    Share on other sites

    Posted · Cura 5.3 Printer definition file in user configuration folder not being read (wrong mesh used)

    Thanks for the info Cuq

     

    The predator.def.json file in my local user definition folder is the original file with my original file name. The Cura created file in the Cura install folder is the file that was submitted and has some different information including a different mesh name.

     

    Assuming that Cura is reading my local predator.def.json file, I am not clear why it is no longer using my custom mesh and texture files. They are stored in my local config folder in the meshes and images folders.

     

    Just to test if my local predator.def.json file mesh is being used I copied a version of my obj file into the Cura install meshes folder and started Cura again. It appears to still only use the mesh file named in the Cura installation predator.def.json file and not the one listed in my local config folder. I then changed the mesh name in the Cura installation predator.def.json file to match my mesh name and it works as expected.

     

    Unless I am missing something this would indicate to me that, the mesh can be stored in either the Cura meshes folder or my local meshes folder but Cura will ignore the mesh defined in my local predator.def.json file and only uses the name specified in the Cura install predator.def.json

     

    If this is the case, I can't see how I can over-ride the defined mesh file using my local predator.def.json file

    Unless someone can clarify this for me I guess my only option is to clear out my installation and rebuild everything from scratch or just keep changing the install definition file every time I upgrade.

     

  • Link to post
    Share on other sites

    • Solution
    Posted · Cura 5.3 Printer definition file in user configuration folder not being read (wrong mesh used)

    Don't see the problem.

     

    You just need to create a mypredator.def.json  and mypredator_extruder_0.json  files in your local folders  and rename the name into "My  Anycubic Predator"

     

    image.png.bc392510267d9c08d2da1bd4fa70eefe.png

     

    Don't forget to create in your local Quality folder the mypredator_*.inst.cfg files.

     

  • Link to post
    Share on other sites

    Posted · Cura 5.3 Printer definition file in user configuration folder not being read (wrong mesh used)

    Thanks Cuq.

     

    I just changed the name of my existing predator.def.json file and it now displays the proper mesh. it still references the original extruder and cfg files so i am going to run this for a while to see if it works and I don't get any other errors.

    I'm pretty sure I put everything back to stock. I'll probably have to wait for the next upgrade to be positive it solves all the issues but it appears to be fixed for now.

     

    The funny thing is that I thought I had already done this but when I added a new printer I got a configuration error. I guess I must have made some other change at the same time as now, when I add a new printer, it works fine.

     

    Thanks for the help.

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 7 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    ×
    ×
    • Create New...