Jump to content

Sometimes cura adds a .0 to the temperature, sometimes not


luc_vienna

Recommended Posts

Posted (edited) · Sometimes cura adds a .0 to the temperature, sometimes not

It is hard for me to reproduce. After going to Cura 5.3.1, i started having a problem, an error when printing with Klipper. On ALL my printers (CR10 S pro, Ender 3 S1 pro)

It stopped printing before it had really started.

 

I found the error. In my printer start sequence I have added following line:

 

BED_MESH_PROFILE LOAD=default{material_bed_temperature_layer_0}

This used to translate in the gcode to:

BED_MESH_PROFILE LOAD=default62

as I have a Mesh profile called default62, it would load and use it and it would work fine.
Now i checked the gcode and it reads now: BED_MESH_PROFILE LOAD=default62.0

And that one does not exist.

So what I did is I created new profiles with the .0 at the end. default62.0 for PLA, default70.0 for PETG etc..
it worked for a day or two.. suddenly the same error:


I checked the gcode again.. and now it was back to default62 instead of default62.0 (in the meantime I had erased the profiles without the .0).

It seems that depending what printing profile i am using, it translates {material_bed_temperature_layer_0} to 62 or 62.0

 

As a momentary workaround i have now saved both mesh profiles, default62 and default62.0, but it is annoying not to know when it changes the output. (its probably a difference between float() and int() somewhere.

 

I had suspected that the printing profiles I had created in earlier versions of cura keep the 62, and that newly created profiles in cura 5.3.1 add the trailing .0

 

But it seems that i am wrong: i have just created a new profile, and it has NOT the trailing .0

Please help if someone knows what is going on.

 

YES I know i should write a completely different startup in a klipper macro, but as fast solution this has worked fine and was working for more than 6 months now. I can live with the doubled mesh profiles, but it would be a lot easier and give me a better feeling to know when it does one thing, and when the other.

 

Luc

Edited by luc_vienna
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
        • 18 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
        • 0 replies
    ×
    ×
    • Create New...