Jump to content

Z Axis Offset won't go negative


ShipModeler
Go to solution Solved by ShipModeler,

Recommended Posts

Posted · Z Axis Offset won't go negative

I am trying to set the Z Axis offset within Cura and I am having an issue. I am using Cura 5.3. I tried installing the add-on for Z offset but it won't take a negative number. If I use a positive number (3.3mm) then it makes the distance between the nozzle and bed 6.6mm

 

So I thought I would just set it in the GCode startup. Again no luck. 

This is the code I used

 

; Ender 3 Max Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes
G29
G92 Z-3.3 ; Z offset setting
;G420 S Works for stored leveling settings
G1 Z2.0 F3000 ; Move Z Axis up little to

 

The line "G92 Z-3.3 ; Z offset setting"  seems to make the distance between the nozzle and the bed 6.6 whether the setting is Z3.3 or Z-3.3

 

Next how would I do a pause in GCode such that it would wait for me to acknowledge. I would like to have Cura pause the print right after the G29 (Level bed) command but I would need it to keep the bed and nozzle temp constant.

Thanks Ray

  • Link to post
    Share on other sites

    Posted (edited) · Z Axis Offset won't go negative

    I thought most people adjusted the Z axis offset in their printers, but I've come across plenty of situations where people need odd fixes for things, so I'm not here to judge.

    If your nozzle is starting high enough to move it down 3.3mm, you could try the following:

    G91 ; Relative positioning
    G0 Z-3.3 ; Move Z axis down 3.3mm
    G90 ; Absolute positioning
    G92 Z0 ; Set current Z position to 0

    Some Creality printers don't obey all commands, so I can't guarantee the following will work, but to make it pause and wait for you, it's just

    M0

    I prefer to let my printer tell me where it's up to but not wait for me, so I get it to beep and pause for a few seconds:

    M300 P500 ; Play tone at default frequency for half a second
    G4 S5 ; Waits for 5 seconds

     

     

    A few more notes on your code:

    53 minutes ago, ShipModeler said:

    G28 ; Home all axes
    G29

    G28 disables bed levelling. G29 doesn't necessarily turn it back on (some printers will, some won't). I run an M420 S after my G28 to make sure bed levelling is enabled.

     

    53 minutes ago, ShipModeler said:

    ;G420 S Works for stored leveling settings

    M420 S enables bed levelling. To use specific levelling settings stored in the printer's EEPROM is M420 L<number>.

     

    53 minutes ago, ShipModeler said:

    G1 Z2.0 F3000 ; Move Z Axis up little to

    Ideally, travel moves (without extrusion) are done using G0 to separate them from extrusion moves which use G1

    Edited by Slashee_the_Cow
  • Link to post
    Share on other sites

    • Solution
    Posted · Z Axis Offset won't go negative

    Thanks Slashee, I will try those options.

     

    Just as a note, I was using the printer to control the z offset but for whatever reason it quit retaining the settings even though I tell it to store settings. It did originally and then just quit storing them. I think it was about the time I installed the printer driver and connected a computer to the printer. I am no where good enough to tinker with the firmware so i thought if I could have Cura do the necessary steps ( preheat, level, z offset ) it would just be something I don't have to remember. If I can't get it all to work I can always go back to manually doing the steps.

     

    Thanks Again.

  • Link to post
    Share on other sites

    • 1 month later...
    Posted · Z Axis Offset won't go negative

    A lot of printers are set NOT to go below what it classes as zero, the issue effects those trying to setup BL touch's etc, a M211 S0 disables the limit (M211 S1 puts the limit back on) However, use extreme caution as it's easy to slam your nozzle into the bed if you get it wrong

  • Link to post
    Share on other sites

    Posted · Z Axis Offset won't go negative
    2 hours ago, dbrandwood said:

    A lot of printers are set NOT to go below what it classes as zero, the issue effects those trying to setup BL touch's etc, a M211 S0 disables the limit (M211 S1 puts the limit back on) However, use extreme caution as it's easy to slam your nozzle into the bed if you get it wrong

    If you're going to do that then please be aware that it will disable limits for every axis, so a bad command could have your print head constantly banging the edge of the gantry trying to move to a negative or out of bounds co-ordinate.

     

    It's much better to just set a constant offset, depending on your needs.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 27 replies
    ×
    ×
    • Create New...