Jump to content

Cura Takes an Incredible Amount of time to load files


Go to solution Solved by Slashee_the_Cow,

Recommended Posts

Posted (edited) · Cura Takes an Incredible Amount of time to load files

When I try to import files onto the build plate, it takes 10+ minutes for them to load. Does anyone know any fixes to this problem? I'm on a mac, and it's worked just fine up until a few days ago, I've uninstalled and reinstalled it several times, and I still don't know what to do.

 

Edited by Dustin
Removed attachment - please dont upload things like this.
  • Link to post
    Share on other sites

    Posted · Cura Takes an Incredible Amount of time to load files

    What Mac do you have, and what Cura version are you using? Some older Macs will technically run Cura, but in use it can be like crawl Cura.

     

    Also how complex is your model? I've created 300MB+ STL files that have taken several minutes to load in Cura even on my high-end PC.

     

    And can you think of anything that might have changed at the same time you started experiencing this problem? OS update? Started using a different mouse? You'd be surprised how often seemingly completely unrelated things can mess each other up.

     

    You could also try doing a clean reinstall of Cura but move the configuration folder somewhere else on your hard drive instead of deleting it entirely so if it doesn't solve the problem you can restore all your settings just by moving it back.

  • Link to post
    Share on other sites

    Posted · Cura Takes an Incredible Amount of time to load files

    I do have a pretty old mac, but Ive used it for months without any issues and all the sudden its a problem. I've just tried to slice some benchy files so far. I haven't changed a single thing on my settings in a long time, the only thing I can think of is that I hadn't used it for a couple weeks, but I don't expect that would do anything. I've noticed now that once I wait that initial wait time, files will go in just fine with just a second or two of wait time.

  • Link to post
    Share on other sites

    • Solution
    Posted · Cura Takes an Incredible Amount of time to load files

    You're not the only one, there's been reports of this before.

    The solution someone offered (not sure if it worked) last time (or the time before, or... something):

    1. Click Marketplace at the top right
    2. Click the gear icon at the top right of the marketplace window
    3. Scroll down to the "USB Printing" plugin (it'll be in the Bundled Packages section) and click Disable

    Especially if that works for you (although even if it doesn't) you should probably submit a bug report detailing the situation.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...