Jump to content
Ultimaker Community of 3D Printing Experts

UM1 spare parts nightmare


Recommended Posts

Posted · UM1 spare parts nightmare

I bought the Extruder Drive Upgrade and the Knurled Drive Bolt Kit on the Ultimaker store.

Here's my Experience :

-On the 14th of May a package arrives containing the full Knurled Drive Bolt Kit and ONLY the screws for the Extruder Drive Upgrade...nothing else.

-On the same day I opened a ticket with the support reporting the issue.

-Today (4th of June), after endless communications and delays from the support, a package finally arrived. It contained all the parts for the Extruder Drive Upgrade, but ONE. (and no, it wasn't the screws which were missing).

I am now AGAIN waiting for the support to reply and I wonder how long it'll take for them to send out the missing piece of plastic.

It's hilarious and frustrating at the same time, not only that the first order was screwed up, but that the items sent out to fix the issue, were WRONG again!

Ultimaker, how much are these issues costing you?

Not only as a matter of customer satisfaction, but as actual shipping costs for this mess.

Can't you put in place some basic quality controls?!?!

 

  • Link to post
    Share on other sites

    Posted · UM1 spare parts nightmare

    Hi Antiklesys,

    Thank you for your post.

    I am sorry to hear that it has been quite a troublesome path so far and it has proven to be difficult to get you the right parts.

    Could you send me the ticketID of your support ticket so I can look into it?

    Also I did not quite understand what you meant by you received only ONE..

    One what?

    Thank you for your time, and lets solve this asap.

     

  • Link to post
    Share on other sites

    Posted · UM1 spare parts nightmare

    Hi SandervG,

    Ticket ID is: VDN-889-99063

    What I meant is that I received all parts, but one is missing.

    If you can open the ticket I have sent you, I have attacched 2 pictures of the problem.

    One is taken from your website, from the store page, in which I circled in red the part which is missing.

    The other picture is a picture of the package I received, where you can see there are all parts, but the one marked in red is missing.

    I hope I won't have to wait again several weeks to get this issue sorted :/

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...