Jump to content
Ultimaker Community of 3D Printing Experts

Slice-ing error: ValueError: expected length 2, got 1


jjshortcut
 Share

Recommended Posts

Posted · Slice-ing error: ValueError: expected length 2, got 1

Hi Daid,

Today I installed Cura RC3 on my windows PC but I'm having trouble slice-ing my models, it's giving me the following error: "ValueError: expected length 2, got 1" which happens on every model I load... Any idea's? Thanks!

GUI_error_cura.png

and

Cmd_error_cura.png

  • Link to post
    Share on other sites

    Posted · Slice-ing error: ValueError: expected length 2, got 1

    I've found the bug. It happens if you never touched the start/end GCode.

    Quick fix is:

    -Use "expert->normal mode"

    -Goto the "start/end gcode" tab

    -Click the "end.gcode" on the left

    Done. That's all. This causes the default start/end code to be stored and used properly.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...