Jump to content

msurunner

Member
  • Content Count

    274
  • Joined

  • Last visited

Everything posted by msurunner

  1. Yep, that's kinda what I'd be afraid of too, but I don't know any other "convenient" way of building it :(
  2. What if we went in reverse? What I'm seeing for most of the dual extruder setups, one would either be used for a support material or for a detailed part of the model. What if you used a .2mm nozzle? Then the support material wouldn't be at thick, thus easier to snap/dissolve off, the detailed section would be even more detailed, and we would lower oozing while it sat idle. Just a thought...
  3. The way I'm seeing it, you would be essentially replicating SG's direct drive, but with a ball screw as one of your axis. if you were to try to connect the belts to the opposing axis, you would need to have a series of couplers with gear sprockets attached to axis sections at the beginning and end of your ball screw to maintain your identical gear ratios in the two axis. I only foresee that leading to inaccuracies. I think you need to replace the one drive axis with your ball screw and leave the other alone. Then you need to modify the carriage bar sections to have a lower friction bearing on the axis you left alone and a ball screw coupler on the drive side. That may mean you would want to bump up the thickness of the carriage bar section as well, which means you would need to swap out bearing in the print head and thus update the wooden box. That doesn't seem to be like too much of a hassle if you are already ditching the hotend. Of course this is all speculation here. You are the first person trying to do this with an Ultimaker, to my knowledge. I think what you might be better served with doing, after looking at all that would need to be done, would be getting your hands on some acrylic/sheetmetal, your ball screws and some servos and building it from scratch. Really, all you are using at this point are half the axis rods, the servos, the outer box, the control board, the power unit and some other smaller parts. Since we already talked about reworking the box to something that will ensure less deformation around bearings and allowing for two additional axis shafts for the build platform, I think it's safe to say scrap that. Now we're left with re-engineering the build platform to have four points of contact with axis, which means scrap the platform at least, leaving you with two axis, the bearings and the ball screw. My opinion, test to see how close you are out of the box (double check the squareness and alignment of your build). If the standard setup isn't going to cut it, you are better served getting the Arduino board and customizing your printer to meet more exacting standards. If you are buying all that stuff to build it up anyways, you are only a stones throw for a complete build, which would give you two printers. You could then either sell your Ultimaker or use it for enlarged modeling of what your custom one is doing.
  4. Okay, so, just to be clear, you are planning on reworking the slicing software anyways to ensure the high precision you are looking at, correct? And reworking the extrusion to a cell dripper, thus having the accuracy you want from your material application, correct? If so, then I would say each of your three steps would improve accuracy. Though for step 1, I would replace the linear bearing on the drive axis with you ball screw gear and leave the linear bearing on the parallel side, thus not needing any belts (Assuming you would direct connect these axis like the z axis is done). I would say pursue this over changing gear ratios and keeping the belts. This would result in fewer moving parts that can wear/tear/generate inaccuracies/backlash opportunities.
  5. The steppers would be working harder because if you were to dial down the gear ratio, you would increase the amount of travel it would have to incur to complete the same object. IE, if we double the gear ratio, thus making it theoretically more accurate, we would require twice the input from the stepper. Your steppers would be running nonstop, thus getting quite warm. Plus, you would be running at half the speed, thus taking twice as long to finish the print.
  6. viewtopic.php?f=6&t=1429 ^I believe this is what they are talking about in regards to gearing the motors... If you were to gear down the steppers you could theoretically improve accuracy, though they are pretty accurate as it is. You would also be dealing with a slower print speed and would probably want to have additional cooling for your steppers as they would be working that much harder to complete the prints.
  7. I believe it does to an extent... Have you changed any of your speeds though? When I bumped mine up was when I started noticing this more. Flowrates aren't dynamically changed based upon speed as far as I can tell (Daid, please correct me if I'm wrong). For instance, if your printer slows down towards the top of a conical shaped part because of minimum layer time, the flow remains the same, thus you get a thicker line there again. The reverse is also true in my experience. But, that could just be my experience.
  8. My first thought would be the difference in speed between the first layer and your subsequent layers. Running at a slower speed increases the chances of sticking but also lays down a fatter line of material than higher speeds. Have you tried either slowing your print speed during the upper layers or upping your print speed during your initial layer?
  9. That seems like a cool program Diad, I'll have to check it out a bit more. I'm using West Point Bridge Designer for my class right now and having one of my advanced drafting kids helping to convert the bridge print outs into AutoCAD extrusions of the spans, thus it teaches my Tech Ed kids some design skills and allows for practical application in my drafting class (not to mention helps keep me from getting overloaded with extra drawings to create).
  10. Alright so here's my thought: I'm a highschool teacher using my Ultimaker in the classroom right now to showcase 3D printing and the ability to test and model designs with it. I think it would be very cool if there are others out there with similar usage of their tools to share the ideas/lessons they are using their Ultimakers for. For instance, I'm currently working on a bridge design unit where I will print and test to failure the students designs on the Ultimaker. I'm also designing the "testbed" to be printed on the Ultimaker. If this collaborative sharing works, I'm more than willing to share my ideas and designs here with anyone else. This forum seems to be the best opportunity to engage others who may have ideas on what to use the Ultimaker and it's potential in the classroom. Please share some ideas! Thanks!!!
  11. Personally, I think that between retraction, software upgrades (enabling an active cooling/dual cool parameter like snowygrouch and I have been discussing in the "Hotend solution?" thread), and some hardware upgrades for active cooling, oozing shouldn't be an issue, even for dual extruder setups... In other words, as far as hardware goes, KISS...
  12. Okay, so super exotic solution: a variable geometry shroud to direct airflow to the printhead right away, and to the bed after the first layer coupled with a Daid Cura fix to add a heatsoak run-time option in the slicer.... Readily achievable solution, ignore cooling the printhead until after the first layer, then utilize the dual outlets coupled with said Daid Cura option for heatsoak.
  13. Haha, good, I'm glad you came to the same conclusion I was trying to get to. I was about halfway through your post and was trying to figure out how to better explain it when I hit your edit. Yes, my idea would be simply to have a smaller, second output in the shroud to the PEEK part. If we do lazy math and assume perfectly clean fluid transfer, you could theoretically take a third or whatever of the normal output, neck it down while diverting it to the PEEK, thus increasing its velocity and cooling ability, while still allowing for a large volume to cool the part being printed. I personally don't think there is a HUGE cooling need for the PEEK, unless printing slower speeds and higher temps (Exotic materials and/or ultra quality), but I think the more improvement we can make the better. Also, I rarely run my cooling fan at full output and it seems to have enough airflow that if amped up, I think it out to support a dual outlet... Let me know how your design is looking Calum and maybe we can collaborate on it...
  14. Here's my thought, maybe someone has already tried it and it's not intellectually sound or it's already available and I just don't know it. What if someone created a fan shroud that cooled the part printed, as well as the PEEK part? Thus, we save on weight from snowygrouch's design (BTW, just got our first snow here in Billings, MT, USA), by keeping with a single fan. I have to think that by doing this, we could also turn the fan vertical and bring it closer to the hotend box, thus lowering the torque on the hotend assembly (I know it's not large anyways, but still). Thoughts? Anyone feeling ambitious? I might try modeling if someone's thinking it sounds like a legit idea...
  15. Slicing in Cura allows you to determine your overlap percentage, which you can bump up if your machine is accelerating back too quickly to provide a good infill to perimeter bond (had to tweak myself)... I don't think it's a mechanical issue due to the fact you say it is consistent..
  16. Way cool Michael! I'm curious what the weight difference will be, or do you not care?
  17. I would +1 phut. I've been able to transition colors in the middle of prints (very cool for logo extrusions, but requires some trial and error) by snipping pieces of filament and creating "queues" of filament. If there isn't a complete pathway to the head I don't think that would be possible...
  18. I have moved my filaments onto a bar that leaves about a meter of distance from the spool itself to the extruder. I have found so far that this not only cleans up the back of the machine/worktop, it tend to allow the filament the time and flexibility to straighten itself out/release its package memory. Still a recent move, but I have been VERY impressed thus far...
  19. Also, it seems as though the extruder motor is running FAR too much for the amount of material pushing through the print head...
  20. I think that may have been the issue. I reflashed it with Marlin 2.0 from Cura and swapped/rechecked connectors. My only issue now is adjusting things I think... I can't seem to maintain a consistent flow rate through the printing of a part. I've tried turning up the temp to 260 and slowing the speed down to 50% (which seems to work well to start) but by the end of a part it seems like the print head is starved for PLA.
  21. I tried to move the print head with the Ulticontroller in its menu, but the only movement I was able to get was the autohome function. It would not respond to moving the axis or heating the print head. I also tried to connect to it using ReplicatorG, but it keeps failing to make a connection, serving up a RTS failed to reset error. As I connect the UltiController now, I show only blocks across the display (regardless of cable orientation). Is there a place to download the Marlin 2.0 firmware outside of ReplicatorG/Cura? If not, is Cura the better option? If RepG, which version? Sorry for the fourteen hundred questions!!!
  22. Okay guys, so I'm a new teacher that just assembled an Ultimaker for use in my classroom. I purchased with it the UltiController. I assembled it and it had some issues of not allowing the user to control it directly from the UltiController. It did, however, allow for it to find home and displayed information on the UltiController, it just wouldn't allow me to use the controller to move the axes or initiate the heater. After reading more in depth, I assumed my Ultimaker was pre-loaded with 5D (correct?) and that I needed to upgrade the firmware to Marlin to utilize the Ulticontroller (correct?). I upgraded the Arduino to Erik's Marlin and tried it again. Now the UltiController does not display any information, despite switching cables around. Given that I was able to send information and receive information before the firmware update, I'm doubting the cables would be the issue (correct?). At this point, I'm just hoping to connect it to a CPU unit and test it's print settings to ensure everything works, but now I'm unable to connect to the machine in ReplicatorG, throwing an unable to reset error. Thoughts? Having stepped into a room with some other serious issues, I'm hopeful I can concentrate on those for a couple days and that you Ultimaker Geniuses have the simple answer my underslept mind missed. Thanks guys!
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!