Jump to content
Ultimaker Community of 3D Printing Experts
chrisw

Using Pauseatz to add extra extrusion for priming the nozzle after resuming?

Recommended Posts

Pauseatz works great.  I'd like to modify its script in the gcode, making it extrude a lot of filament to purge the nozzle after Resume Print   is selected.  So far I've only been able to make it extrude a little extra for some reason, even though it seems like I'm telling it to extrude a lot.  I'd like it to extrude as much as you see during the standard Ultimaker2 start of a print.

Here's  a sample gcode script written by Pauseatz:

;LAYER:15
;TYPE:CUSTOM
M83
G1 E-5.000000 F6000
G1 X200.000000 Y40.000000 F9000
G1 Z15 F300
M84 E0
M0
G1 E5.000000 F6000

G1 E5.000000 F6000 <

G1 E-5.000000 F6000
G1 Z5.000000 F300
G1 X183.018000 Y131.416000 F9000
G1 E5.000000 F6000
G1 F9000
M82
G0 F9000 X183.018 Y131.416 Z4.000
;TYPE:WALL-INNER

What am I missing here?

Chris

Edited by Guest

Share this post


Link to post
Share on other sites

Nevermind on this. I think I just need to read an experiment. I'm getting weird results from some of my attempts, such as the filament getting retracted almost back to the feeder. I think that's because I was not understanding the relative vs absolute modes. So I just need to read and learn more about gcode

Share this post


Link to post
Share on other sites

I think that's because I was not understanding the relative vs absolute modes.   So I just need to read and learn more about gcode

 

Yep. That's what the M82 and M83 commands are good for...

I think this plugin uses G90 and G91 too (not sure)

And while you're at it, keep in mind:

While using UltiGCode the E-coordinates are interpreted as mm^3 (volumetric).

A relative value of +400 should give you an extrusion of approx. 62mm - if not there was something wrong with the relative/absolute mode... :)

And yes - the extrusion of very large distances is prevented by the firmware - the limit is 1000mm per command (approx. 6379mm^3 for 2.85mm filament). If you try a larger (relative) move of the E-axis - it's just ignored.

A connected printrun/pronterface is not a bad idea for debugging btw.

You get a warning on the serial console in those cases.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the tips! I've been playing around with various settings and code changes all day long. A few times it seemed like I had it working: The system would pause, the head would move to a corner and sit/wait. The long extrude would occur (either in place, or as the head was moving across the X or Y axis, depending on which line I'd written for that particular attempt). Then the head would rush to its resume position.. at the right spot in the print, head primed, all ready to go. I was all excited because I had this issue resolved, I was sure...

Then a retraction would occur right before the printer starts writing. So no filament is extruded as the head dances around over its target.

There is no line in the gcode telling the system to make that last retraction. It seems like I'm fighting the firmware. So I even tried using M207 and 208 to set the retract length to 0 near the end, before the rogue retract occurs, then manually set it back to 8 as the writing begins. That didn't work either.

I haven't used your idea of running printer/pronterface yet. That's next on my list when I have time to blow on this

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy