Jump to content
Ultimaker Community of 3D Printing Experts

Tweak At Z reset at height


patrick181

Recommended Posts

Posted · Tweak At Z reset at height

UM2

Cura 15.04

TweakatZ 4.0.2

I have multiple prints of the same part that need fans on at 9mm Z. Problem I'm having is that TweakatZ does not reset at the beginning of the next print/part and leaves the fans on for the remaining parts. Cura is set for Print One At a Time. Any ideas how to accomplish this?

TweakatZ documentation indicates a "Reset previous values when printing one-at-a-time" if this the same thing?

Captur22222e.thumb.JPG.7d6a6f40443d2a0fdd04208afec91dcd.JPG

Captur22222e.thumb.JPG.7d6a6f40443d2a0fdd04208afec91dcd.JPG

  • Link to post
    Share on other sites
    Posted · Tweak At Z reset at height

    Congrats, you pointed me to a bug. Reset on an UM2 is not properly done if the setting is visible within the gcode (i.e. a machine setting). However, this should exactly lead to not changing any behavior which would lead to Cura's default which is an M107 at the start of the layer. I guess I will have to look at this in a quiet minute...

    Would be nice if you could submit an issue on Github.

  • Link to post
    Share on other sites
    Posted · Tweak At Z reset at height

    Thxs.

  • Link to post
    Share on other sites
    Posted · Tweak At Z reset at height

     

    @patrick181: Any news yet?

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...