Jump to content

Cura stuck on splash screen - log included


Recommended Posts

Posted · Cura stuck on splash screen - log included


I just installed Cura on windows 10 but i can't start it up because it doesn't go past the splash screen. does anyone know what to make of the log? thanks

ERROR:Cura\util\pymclevel\materials.py:Failed to read minecraft.yaml using pkg_resources. Trying pymclevel\minecraft.yaml instead.
Traceback (most recent call last):
 File "Cura\util\pymclevel\materials.py", line 159, in addYamlBlocksFromFile
   import pkg_resources
 File "C:\Program Files (x86)\Cura_15.04.4\python\lib\site-packages\pkg_resources.py", line 698, in 
   class Environment(object):
 File "C:\Program Files (x86)\Cura_15.04.4\python\lib\site-packages\pkg_resources.py", line 701, in Environment
   def __init__(self, search_path=None, platform=get_supported_platform(), python=PY_MAJOR):
 File "C:\Program Files (x86)\Cura_15.04.4\python\lib\site-packages\pkg_resources.py", line 96, in get_supported_platform
   plat = get_build_platform(); m = macosVersionString.match(plat)
 File "C:\Program Files (x86)\Cura_15.04.4\python\lib\site-packages\pkg_resources.py", line 221, in get_build_platform
   from distutils.util import get_platform
ImportError: No module named distutils.util
Traceback (most recent call last):
 File "C:\Program Files (x86)\Cura_15.04.4\python\lib\site-packages\wx-2.8-msw-unicode\wx\_core.py", line 14660, in 
   lambda event: event.callable(*event.args, **event.kw) )
 File "Cura\gui\splashScreen.py", line 15, in DoCallback
 File "Cura\gui\app.py", line 103, in afterSplashCallback
   from Cura.gui import mainWindow
 File "Cura\gui\mainWindow.py", line 22, in 
   from Cura.gui.tools import minecraftImport
 File "Cura\gui\tools\minecraftImport.py", line 14, in 
   from Cura.util.pymclevel import mclevel
 File "Cura\util\pymclevel\__init__.py", line 4, in 
   from indev import MCIndevLevel
 File "Cura\util\pymclevel\indev.py", line 63, in 
   from level import MCLevel
 File "Cura\util\pymclevel\level.py", line 7, in 
   import blockrotation
 File "Cura\util\pymclevel\blockrotation.py", line 1, in 
   from materials import alphaMaterials
 File "Cura\util\pymclevel\materials.py", line 292, in 
 File "Cura\util\pymclevel\materials.py", line 168, in addYamlBlocksFromFile
   f = file(path)
IOError: [Errno 2] No such file or directory: 'pymclevel\\minecraft.yaml'

  • Link to post
    Share on other sites

    Posted · Cura stuck on splash screen - log included

    I'm having a similar problem.

    Running Octoprint through M3Dfio and the screen to resize, etc. has disappeared.

    Running Cura on its own results in the splash screen which disappears on a mouse click.

    Uninstalling and reinstalling has no effect.

  • Link to post
    Share on other sites

    Posted (edited) · Cura stuck on splash screen - log included

    Uhm. The solution is very silly I'm affraid. Remove minecraft from your system.

    Well that would help if I had Minecraft on my sytem.

    I have very little on the computer because I use it almost exclusively for 3D printing.

    I tried messing around with glut.dll as suggested in previous posts but that didn't work.  Also it is present in one of the python subdirectories

    The only software I have installed recently is GiMP.

    Edited by Guest
  • Link to post
    Share on other sites

    Posted · Cura stuck on splash screen - log included

    I had the same problem. (possible cause: using AVG TuneUp registry clean-up).

    Uninstalling Cura and Minecraft didn't help.

    I found that it helps to make the following change to Cura\util\pymclevel\materials.py



        def addYamlBlocksFromFile(self, filename):       if  yaml is None:           return




        def addYamlBlocksFromFile(self, filename):       if True:           return


    • Like 1
    Link to post
    Share on other sites

    Posted · Cura stuck on splash screen - log included


    I had the same problem and now with this workaround Cura starts :)

  • Link to post
    Share on other sites

    Posted · Cura stuck on splash screen - log included


    Wow after a week of frustration, this resolve my issue!

    Big Thanks!

  • Link to post
    Share on other sites

    Posted · Cura stuck on splash screen - log included

    I have the same error on Win7 trying to install Cura14 for my UM original. Never played or installed Minecraft.

    The file the error refers to is located in C:\cura14\Cura\util\pymclevel\minecraft.yaml

    Editing Cura\util\pymclevel\materials.py as suggested did not help.

  • Link to post
    Share on other sites

    Posted · Cura stuck on splash screen - log included

    I finally solved it on my Win7 computer. I am using UM original after a very long time. I tried newer Cura 2.6 version but could not get same results as using older Cura 14 version.

    The error was obvious:

    "ImportError: No module named distutils.util"

    I already had Python installed. So I copied folder C:\Python27\Lib\distutils to C:\cura14\python\Lib\distutils and now the error is gone.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...