Jump to content

Run Cura on linux


Recommended Posts

Posted · Run Cura on linux

I' ve run into the limits of memory usage with Cura and windows. there's also a thread about slicing complex models on windows, cura displays a message about a memory problem. I have a PC with 64 bit windows and 24GB of memory, so memeory enough. Still I can't slice big STL file. KISSlicer does slice my model but I can't get it to work with my ultimaker, whatever I do it keeps under extruding.

In the previous thread is written that Linux is much better with memry than windows. I wis to give it a try. I already installed Linux ubuntu but I don't know how to run Cura on it.

Can someone explain what i need to do to get Cura to run on Linux.

I tried Linux ubuntu 10

I download the source files from DAID + package.sh

in a terminal window i wrote: sh ./package.sh

but then I get a list of error messages: elif not expected, function: problem with checkTool.

I've read a buch of articles about compiling from source code to a working linux executable but I still don't understand it fully, can someone help me?

kind regards,


  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    I'll borrow this thread a bit as I'm also having problems running Cura in linux. After installing the missing python stuff I can get Cura to run and open the model with it just fine. But when I hit "Prepare print" I immediately get the something went wrong during slicing error message, the log doesn't show anything either so I'm not sure what to try here. I installed/downloaded pypy 1.9 from the official website but that made no difference.

    I'm running cura 12.10 in Opensuse.

    I'd use windows for this but unfortunately I have a pretty large model that hits the 2gb limit.

  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    Beeone, did you install pypy 64bit? Usually this error happens on Linux when you have a 32bit pypy on a 64bit only system.

    As for "what to do", the short list to get Cura working on Ubuntu is:

    - Download the latest release

    - Install the packages: python-numpy, python-pyopengl, python-serial, python-wxpython (these package names could differ)

    - Run the cura.sh script to start Cura.

    Linux installation support for Cura isn't the best right now, as it's a low priority target with lots of differences between systems.

  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    I had the 64bit version installed yes. I was able to get it working now though, the problem was that I had renamed the extracted pypy dir to match the original dir in the cura folder. For some reason that was not good but now it works.

  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    I had a similar problem: I'm using Ubuntu 12.10 64bit and downloaded the .deb from the ultimaker download section and installed all the dependencies. When i opened Cura and pressed the prepare button, the word "starting" came in the bottom left corner but nothing happend. I tried many things to get it to work. The I removed cura and went here: https://github.com/daid/Cura and build and installed the Cura development version with these commands:



    git clone https://github.com/daid/Cura.git

    sudo apt-get install python-opengl

    sudo apt-get install python-numpy

    sudo apt-get install python-serial

    sudo apt-get install python-setuptools

    cd Cura

    sudo ./package.sh debian

    sudo dpkg -i ./scripts/linux/Cura*.deb

    Worked like a charm! :)

    I don't know what's wrong with the first .deb file but maybe this helps people who have the same problem.

    Thanks Daid for the very godd and easy to understand documentation on github!


  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    I had to make a completely new installation of linux because of some issues. Now when I do everything like bevore to run cura, it hangs at the splash screen and cura won't open. When I start cura through the terminal I get this output:

    lukas@workstation:~$ cura

    Traceback (most recent call last):

    File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14665, in <lambda>

    lambda event: event.callable(*event.args, **event.kw) )

    File "/usr/share/cura/Cura/gui/splashScreen.py", line 16, in DoCallback


    File "/usr/share/cura/Cura/gui/app.py", line 39, in afterSplashCallback

    from Cura.gui import mainWindow

    File "/usr/share/cura/Cura/gui/mainWindow.py", line 9, in <module>

    from Cura.gui import preview3d

    File "/usr/share/cura/Cura/gui/preview3d.py", line 15, in <module>

    from OpenGL.GLU import *

    File "/usr/lib/python2.7/dist-packages/OpenGL/GLU/__init__.py", line 4, in <module>

    from OpenGL.raw.GLU import *

    File "/usr/lib/python2.7/dist-packages/OpenGL/raw/GLU/__init__.py", line 6, in <module>

    from OpenGL.raw.GLU.constants import *

    File "/usr/lib/python2.7/dist-packages/OpenGL/raw/GLU/constants.py", line 7, in <module>

    from OpenGL import platform, arrays

    File "/usr/lib/python2.7/dist-packages/OpenGL/arrays/__init__.py", line 22, in <module>


    File "/usr/lib/python2.7/dist-packages/OpenGL/arrays/formathandler.py", line 37, in loadAll

    cls.loadPlugin( entrypoint )

    File "/usr/lib/python2.7/dist-packages/OpenGL/arrays/formathandler.py", line 57, in loadPlugin

    handler = plugin_class()

    File "numpy_formathandler.pyx", line 30, in OpenGL_accelerate.numpy_formathandler.NumpyHandler.__init__ (src/numpy_formathandler.c:1195)

    AttributeError: 'module' object has no attribute '_configflags'


    What have I done wrong this time? And what can I do to fix this?

    Thanks in advance!


  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    It's something that the Ubuntu maintainers broke in the numpy or PyOpenGL packages.


  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    Ah OK.

    I went here: https://launchpad.net/ubuntu/+source/pyopengl

    and downloaded the .deb of version 3.0.0-0ubuntu1 for the Lucid Lynx


    Now everything works again! Maybe this is helpful for users with the same problem.

    Thanks Daid for the info! =)


  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    The package.sh script is to build a release. What you want to download is not the latest sources, but the latest release from http://daid.github.com/Cura/


    Hi ,Daid:

    I install Cura on Debian 7.0.0 (GNU/Linux) ,I can't run it as ordinary user, but it can run as root ,but it can't load model file.

    AND get :Traceback (most recent call last):

    File "/usr/share/cura/Cura/util/sliceEngine.py", line 161, in runSlicer

    self._process = self._runSliceProcess(commandList)

    File "/usr/share/cura/Cura/util/sliceEngine.py", line 294, in _runSliceProcess

    return subprocess.Popen(cmdList, stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, **kwargs)

    File "/usr/lib/python2.7/subprocess.py", line 679, in __init__

    errread, errwrite)

    File "/usr/lib/python2.7/subprocess.py", line 1259, in _execute_child

    raise child_exception

    OSError: [Errno 2] No such file or directory

    Closing down


    [1]+ Done cura


  • Link to post
    Share on other sites

    Posted · Run Cura on linux

    How did you install it? Used the deb package or the sources from github?


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...