Jump to content

Solved Weird axis movement mid-print


Recommended Posts

Posted (edited) · Solved Weird axis movement mid-print


i just upgraded my feeder+motor to the one used in the plus model. Everything went fine and it prints... for a few layers then then one axis moves to the limit and goes back to the intended position. (In one attempt this resulted in a huge... retraction motion).

Any idea what the problem is?

Before the upgrade the printer worked fine with tinkergnomes firmware.

After the upgrade I modified the firmware by changing the e-steps, extruder directions and some default retract values because firmware wise those are the only differences between plus and non plus (standard height) machines.

Worrying that something went wrong I now used the original plus firmware but the result is the same.

In the picture I tried to print the speed-test cylinder. The diagonal line is movement from priming to skirt and skirt to print which is fine but the vertical line is where after a few layers the printer moved the Y axis to the front instead of continuing the circular motion (i switched the printer off at that point).

I also tried different gcodes with the same result.



Edited by Guest
  • Link to post
    Share on other sites

    Posted · Solved Weird axis movement mid-print

    I can't explain. But first thing I would do is a factory reset and reinstall the firmware again.

    There is no need to make complicated changes the tinker firmware is readily available for the um2+

  • Link to post
    Share on other sites

    Posted (edited) · Solved Weird axis movement mid-print

    There is no need to make complicated changes the tinker firmware is readily available for the um2+


    I know, but I wanted to keep my settings as the + version increments the eeprom data version and you have to go through the bed levelling again and I wanted to avoid that. "Change a running system as little as possible." ;)

    But I fixed it...

    ...tuns out my SD card failed a bit. Only a bit because it works as normal but sometimes when reading it reads just garbage -> so some gcodes were read wrong which resulted in weird movements.

    Edited by Guest
    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...