Jump to content
Ultimaker Community of 3D Printing Experts
shaiss

Change Start/End gCode in 2.1.1

Recommended Posts

How do I change my start/end gCode in Cura 2.1.1? I noticed it's in the cfg files for under resources/printers, however if I update it there and import a profile from cura 15.x I noticed that end gcode is actually there twice.

So where is the proper place to set this?

Share this post


Link to post
Share on other sites

Start/End Codes are in the .json printer profiles.

C:\Program Files\Cura2.1\resources\machines

Run WordPad as Administrator and then open your machine's .json file.

"machine_start_gcode" and "machine_end_gcode" are the lines you'll want to change. They're both just one big ugly line with embeded \n (newlines), so keep that same format.

Save your changes and then restart Cura.

Share this post


Link to post
Share on other sites

Start/End Codes are in the .json printer profiles.

C:\Program Files\Cura2.1\resources\machines

Run WordPad as Administrator and then open your machine's .json file.

"machine_start_gcode" and "machine_end_gcode" are the lines you'll want to change. They're both just one big ugly line with embeded \n (newlines), so keep that same format.

Save your changes and then restart Cura.

 

Hi,

So I followed your directions to get to my machine's .json file (UMO+) and this was the code in that file..

{

"id": "ultimaker_original_plus",

"version": 1,

"name": "Ultimaker Original+",

"manufacturer": "Ultimaker",

"author": "Ultimaker",

"icon": "icon_ultimaker.png",

"platform": "ultimaker2_platform.obj",

"platform_texture": "UltimakerPlusbackplate.png",

"file_formats": "text/x-gcode",

"inherits": "ultimaker_original.json",

"pages": [

"UpgradeFirmware",

"UltimakerCheckup",

"BedLeveling"

],

"machine_settings": {

"machine_heated_bed": { "default": true }

}

}

This doesnt look right at all but I'm not very good with coding so if you can assit me a little that would be great!

All I'm trying to do is make the printer prime a little more before it starts printing so if you know a better way than to edit the start gcode let me know!

Thanks!

Share this post


Link to post
Share on other sites

Ok, see the "inherits": "ultimaker_original.json", line in your .json file?

That imports settings from that .json file for the UMO+.

Open that file and copy the machine_start_gcode and machine_end_gcode lines into your UMO+ .json file after the machine_heated_bed line. Then you can add your own start/end commands to it.

P.S - I highly recommend giving you modified UMO+ profile a new filename, and ID and NAME (in the .json) file instead of modifying the original. There's less chance it will be lost if/when you update Cura.

Edited by Guest

Share this post


Link to post
Share on other sites

Had same question and your reply was exactly what I needed.  However,

some of the changes I made do not appear in the gcode file generated by

CURA.  For example, I inserted following entries in the

"machine_start_gcode" line following the "M107 ;start with the fan off\n" entry:  

 

 "G28 ;home\nG29 ;run auto bed level\n"

 

Nothing major, just wanted to run G29 as a final check of the bed position

before printing.   I copied the "Prusa i3" .json file, made the above mentioned

changes and renamed the copy "Prusa i3 MOD".

I saved this in the "machines" folder and then started CURA.  I selected "Prusa i3 MOD"

as my printer and saved the "sliced" file to an SD card for my printer.  In reviewing

the file, the "G28" code was inserted but the "G29" code was not.  I manually entered

the "G29" code in the file on the SD card and printed the object.  It worked as

designed.  Why would CURA omit the "G29" entry from the gcode file it created even

though it was in the "machine_start_gcode" ?

Share this post


Link to post
Share on other sites

mikey2,

Post that entire line in a reply. Maybe there is a typo that's getting rejected.

Update: Looked at the gcode documentation and G29 is not supported by the 'Sprinter' firmware. And the entry in that json file says:

 

"machine_gcode_flavor": { "default": "RepRap (Marlin/Sprinter)" },

 

So that may be why it was removed (I'm guessing here...)

So you could try changing it to just "RepRap" ..

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 0 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!