Jump to content
Ultimaker Community of 3D Printing Experts
znib

Cura 2.1.2 crashes into object in "One at a Time" mode

Recommended Posts

I moved from Cura 15.04.6 to 2.1.2 yesterday and tried to print two parts in "One at a Time" mode.

When it started to print the second part, the print head crashed into the first part because it placed the two objects two close to each other.

In 15.04.6 I can set the printer head size, but I can't find this setting in 2.1.2, can anyone tell me where to find it?

Also, when I have a Ultimaker original, with completely original printer head, and I choose "Ultimaker original" as my printer in Cura, why does it not have the correcet printer head size set already?

Share this post


Link to post
Share on other sites

It could be that we made a mistake with the sizes. I've created a bug report on our internal tracker for you.

You can change the head size in the ultimaker_original.json file. The setting you are looking for is called something like machine_head_polygon.

My guess is that this went wrong because we actually hardly have un-modded UMO machines in the office (and never got tested quite right). Shame on us...

*edit* : For our own reference; CURA-1948

Edited by Guest

Share this post


Link to post
Share on other sites

It could be that we made a mistake with the sizes. I've created a bug report on our internal tracker for you.

You can change the head size in the ultimaker_original.json file. The setting you are looking for is called something like machine_head_polygon.

My guess is that this went wrong because we actually hardly have un-modded UMO machines in the office (and never got tested quite right). Shame on us...

*edit* : For our own reference; CURA-1948

 

It's machine_head_with_fans_polygon.

In Cura 15.04.6 it had the following numbers:

Head size towards X min 75mm

Head size towards Y min 18mm

Head size towards X max 18mm

Head size towards Y max 35mm

However, all of them except X max seem to be very optimistic, I'd add at least 5mm to each.

In ultimaker_original.json machine_head_with_fans_polygon I can see 8 numbers, grouped in pairs:

-75, 35

-75, -18

18, 35

18, -18

So the numbers seem to be the same. I don't know if it crashed into the part because the numbers are too optimistic, or if there is a bug somewhere.

Anyway, I think there should be a way to set the printer head size without having to edit a .json file. Even if it comes with correct defaults, many ppl have modified their print heads with other fans, etc.

Edited by Guest

Share this post


Link to post
Share on other sites

I think the order of the points in the polygon are wrong. Plotting those out, in the order given in the json file produces a bow-tie like object.

I think the points should be in this order:

-75,35

-75,-18

18,-18

18,35

 

I see what you mean. Unfortunately, I won't be able to try this until end of next week, maybe nallath can confirm that this could be the problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy