Jump to content
UltiMaker Community of 3D Printing Experts

Install Cura 2.4 on Suse 42.2?


Recommended Posts

Posted · Install Cura 2.4 on Suse 42.2?

Hi there,

Welcome to the forum! :)

I used be on openSuSE. I really liked it!

Taking a quick look in OBS, I do not see that anyone has built a 2.4 yet. There was a 2.3.1 in there, so you do not have to be at 14 or 15 anymore. :)

But also, with Cura 2.4 on Linux, Ultimaker has switched to a different "universal" package system. So, you might try downloading that from the Ultimaker website and give that a go using the instructions/conventions of the new package.

Alternatively, maybe you want to be the first on OBS to make a 2.4 build? :)

Maybe others here can comment. I have not been on Suse for a few years now so I am out of the loop.

Anyway, I hope this helps. Good luck!

  • Link to post
    Share on other sites

    Posted · Install Cura 2.4 on Suse 42.2?
    So, you might try downloading that from the Ultimaker website and give that a go using the instructions/conventions of the new package.

    Hi Krys,

    And that is just my problem. I have download 2.4 but there are no instructions that I can find - either on the web site or within the package.

    I am not familiar with "AppImage" distribution, so I threw it at an unzipper. Which unziped the file but I know not how to install it!

    If AppImage is a new distribution technology, I would have hoped that Ultimaker would have taken a few sentences to introduce us to it?

    I have even been even more reckless and tried to execute the download file (without unzipping) in a sacrificial VM. Want to see the error log? its 22kb!

    Regards, Martin

    • Like 1
    Link to post
    Share on other sites

    Posted · Install Cura 2.4 on Suse 42.2?

    Yeah, I was confused about it too. It seems AppImage is a thing. You can find more info here:


    But I have not actually played with it directly yet. I am still on 2.3.1 for now. I have to upgrade my Ubuntu before I can use 2.4, so I have put it off for a while. :(

    I agree though that Ultimaker should write some words and make them prominently visible for the AppImage Linux install. AppImage is (to me anyway) a new and weird and non-standard way to install software on Linux. So, I would expect that the majority of Linux people have no clue what the heck AppImage is. That puts the burden on Ultimaker, IMHO, to be the teacher and explaing this new (and wonderful?) way of installing things.

    Anyway, hope this helps. Good luck! :)

  • Link to post
    Share on other sites

    Posted · Install Cura 2.4 on Suse 42.2?

    well I just made the Cura-2.4.0.AppImage executable with

    chmod u+x Cura-2.4.0.AppImage

    then run it as


  • Link to post
    Share on other sites

    Posted · Install Cura 2.4 on Suse 42.2?

    Hi Kenjo,

    Thank you for the information. Yes, as I pointed out above, I have also run it.

    Although, having spent a career in the military aircraft industry, I am very wary of pressing any button unless I know the resulting action - It just may be the ejector seat!

    So, I ran it on a VM:


    ~./Cura-2.4.0.AppImage-Install > Cura-2.4.0.AppImage-Install.log


    This has generated a 22Kb log file. What do all the Warnings and errors mean?

    I'm new to this forum, so I can't find a way of uploading my file. Can you replicate? My log file begins and ends like this:


    Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix elementFontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix elementFontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected numberFontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 62: bad aliasFontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 70: bad aliasFontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 78: bad aliasFontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 86: bad alias...bulk of file removed to save space......../bin//cura.sh: line 11:  2046 Segmentation fault      (core dumped) cura $@


    My guess is that "Core dumped" is not good?

    Regards, Martin

  • Link to post
    Share on other sites

    Posted · Install Cura 2.4 on Suse 42.2?

    no that is not good. its also impossible to tell what is wrong as that segfault at the end is actually a programming error so you have to use a debugger to make any sens out of it.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.3 stable released
        In this stable release, Cura 5.3 achieves yet another huge leap forward in 3D printing thanks to material interlocking! As well as introducing an expanded recommended print settings menu and lots of print quality improvements. Not to mention, a whole bunch of new printer profiles for non-UltiMaker printers!
          • Thanks
          • Like
        • 24 replies
      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 18 replies
      • UltiMaker Cura Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 22 replies
    • Create New...