Jump to content
Ultimaker Community of 3D Printing Experts
amagro

Dual Extrusion - temperatures nightmare

Recommended Posts

Hello,

I'm having difficulties to do a dual print without pause the extruders because of the temperatures.

The problem is the M109's (during the cgode, not in the start gcode) before the change of an extruder.

It's normal the extruders temperatures flutuate some degrees celcious, and because of that and with the implementation of M109, every time extruder change a pause will occour.

Already change the Initial and Final Printing, but the problem is the same, now all temperatures are set to 195ºC.

BTW, the extruder pause on top of the model.

How can I solve this situation?

Cura 2.6.2 and helloBEEprusa 3D Printer

Edit:

I found a post-processing script that could help - Search and Replace. I could replace the M109 for a M104, but it will also replace the M109 in the Start Gcode, so this is not the solution.

This plug-in should only affect the generated gcode, and not the Start and End gcode.

Edited by Guest

Share this post


Link to post
Share on other sites

Maybe a parameter to define the amount of variation of temperature in wich should make a pause.

It's very frustrating that the change of one degree celsius could pause an entire print, everytime the extruder change.

I already tried Prime Tower, and  the nozzle that will start to extrude will always stop on top of the print.

Edited by Guest

Share this post


Link to post
Share on other sites

The extruder T1 that will start to extrude, before making the lines in the Prime Tower, goes momentary to the top of the other part made by the T0, and then goes to to Prime Tower. This always happen with both extruders, when there is a extruder change.

This is really strange.

Edited by Guest

Share this post


Link to post
Share on other sites

Maybe a parameter to define the amount of variation of temperature in wich should make a pause.

It's very frustrating that the change of one degree celsius could pause an entire print, everytime the extruder change.

I already tried Prime Tower, and  the nozzle that will start to extrude will always stop on top of the print.

You could edit the marlin and make your own firmware. There are settings that define how close to target and for how much time (5secs) must past after reaching that target. Dive into definitions and definitions adv on marlin and build your own marlin to cut the wait time, if that's what you are looking for.

UM3 doesn't wait that long to hit target to move faster, ofc that means that you will need a very precise PID to avoid fluctuations after hitting target.

Share this post


Link to post
Share on other sites

This is the initial gcode generated by Cura.

 

M190 S60

M104 S195

M104 T1 S195

M109 S195

M109 T1 S195

My suggestion in order to speed up to reach of the extruders temperatures is to change the M190 to M140, then the bed and the extruders could start to warm up at the same time, it not will be necessary to wait for bed the reaches the desired temperature to start warm up the extruders.

M140 S60

M104 S195

M104 T1 S195

M190 S60

M109 S195

M109 T1 S195

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!