Jump to content
UltiMaker Community of 3D Printing Experts

Expensive brick?

Recommended Posts

Posted · Expensive brick?

I think I've got a broken UM board:

Recently bought UM kit, with UltiController - spent the weekend building it meticulously and was mostly successful. I got the system powered up, saw output on the UC, was able to see menus (got the motors to go to home position at front left) etc.

Then moved on to connecting with computer, using Cura 13.04-2 (Linux Fedora 18 x86_64), added myself to the dialout group to be able to get comms permission, ran Cura, cancelled first time wizard, switched to 115200 baud. All OK so far. Then ran first time wizard again - uploaded the latest Marlin firmware and then problems ever since:

Whilst firmware can upload and I can see comms back and forth with Arduino there's nothing from the printer itself apart from the buzz of the fan and the motors getting rather warm.

The display on the UC now just shows a row of white blocks row of blue, row of white and another row of blue. I've adjusted contrast as discussed on the forum to no avail (even tried switching the cables over - no change).

I've re-flashed the firmware several times (uploads and verifies) and get nothing different - I'm now suspecting it's the UM main board but I'm not sure how to diagnose / confirm this - any pointers?

I'd love to get up and running and do my first print but think I've hit an insurmountable brick wall and will have to get the UM board replaced before I can proceed. :(


  • Link to post
    Share on other sites

    Posted · Expensive brick?

    This may sound strange but SEVERAL people had the same problem in the last few weeks and the solution for ALL of them was to carefully (very carefully) remove the arduino board form the main board, then plug the usb into arduino board only (usb powers up arduino just fine). Then upload the firmware one more time. Then unplug, power down and evern more carefully now attach the arduino board back to the main board.

    I know it sounds bizarre but if you search these forums it fixed things for a few recent kits.


  • Link to post
    Share on other sites

    Posted · Expensive brick?

    gr5: thanks for the advice, I've tried as you suggested:

    (<type 'exceptions.ValueError'>, ValueError("invalid literal for int() with base 10: '?'",), <traceback object at 0x42d8cf8>)
    Flashing 89584 bytes
    Verifying 89584 bytes

    I see the tx/rx lights on the arduino flashing as you'd expect during this process, so I'm fairly sure this has worked.

    I re-insert the arduino then re-power the UM - still the same, UC just gives the rows of blocks and nothing for the rest - cura reports communicaiton failure from first-run wizard. I've also tried this with all the wires disconnected from the UM apart from the UC & fan and tried with rebooting PC between flashing and re-connecting things (as sometimes USB doesn't seem to reset). Not sure what to do next really, open to suggestions?


  • Link to post
    Share on other sites

    Posted · Expensive brick?

    phanc60844: Thanks, already tried with UC disconnected same effects - nothing but communication failure and noises like the motors are trying to do something. If it's the voltage on the main board then it's faulty and simply needs replacing as far as I'm concerned.


  • Link to post
    Share on other sites

    Posted · Expensive brick?

    If it's the voltage on the main board then it's faulty and simply needs replacing as far as I'm concerned.


    Of course but you need to determine if the problem is with the board or with the power supply. They are 2 different parts. This is a kit so you are expected (I would think) to experiment a little and use a voltmeter.

    I hope you didn't think this was like buying an hp ink jet. This is a hobbyist kit and the kit isn't perfect. You need to know how to use a screwdriver and a voltmeter and files and such. Fortunately there are people here who can walk you though how to use a voltmeter if necessary.

    So if the power supply is putting out 19V or so while connected to the UM board and the switch is turned on, then it's probably the board. If the power supply voltage drops significantly (say to 9V?) then it's probably the power supply but not 100% definitely. It's also possible the board is draining too much current for the supply to handle. So start out by measuring the voltage.


  • Link to post
    Share on other sites

    Posted · Expensive brick?

    Thanks for the replies and sorry it's taken a while for me to conclude this (I've been out of the country so not had time to play until now!).

    It turns out the issue was uploading firmware via Cura 13.04 on Linux: I booted into windows and ran everything from there and it sprang into life after the firmware uploaded! I'm currently running my first print happily but will try from Linux again after this (just won't be uploading firmware that way again anytime soon!)

    Once again thanks for the help, it's appreciated.


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.3 stable released
        In this stable release, Cura 5.3 achieves yet another huge leap forward in 3D printing thanks to material interlocking! As well as introducing an expanded recommended print settings menu and lots of print quality improvements. Not to mention, a whole bunch of new printer profiles for non-UltiMaker printers!
          • Thanks
          • Like
        • 24 replies
      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 18 replies
      • UltiMaker Cura Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 22 replies
    • Create New...