Jump to content
Ultimaker Community of 3D Printing Experts

First Layer Height

Recommended Posts

I have been having some issues with layer heights recently, some with under extrusion on all layers, but particularly with first layer height issues. When I slice with cura I noticed that the first layer was about 2mm above the bed and I have no idea why. I re calibrated the printer, and printed an old profile/gcode which worked perfectly fine, but anything new doesn't work. Any suggestions?

Share this post

Link to post
Share on other sites

Well the short fix is to load your model, select it, and then select the top icon from the vertical list if icons on left hand side of the window. This displays your x/y/z co-ordinates and I assume the Z co-ordinate will not be showing 0; set it to 0.


What version of Cura was used to create the old gcode and what version was used to create the new version. Are the sets of gcode for the same or for different models?



Share this post

Link to post
Share on other sites

Thank you so much for responding,


It's set to zero. After making sure I tried printing it to see if I had it set to something else for some reason beforehand and it had the same issue. 


It's technically a different model, but it's very similar/different iteration from the same file. I tried resetting all my slicing properties as well in case I screwed something up, which didn't help. I think I used 2.6 or something around that for the old version, and I am currently using 3.2.1. I started having this issue with 3.1, and I thought I had sorted it out but it came back with a vengeance, and I had just brute forced it before to get it to work, didn't actually solve the issue. I can ultimately compensate for it with live z adjustment but it's clearly setting the zero higher when I am slicing new files compared to the old ones. (If I try printing an old file afterwards the nozzle hits the bed).


Also I'm printing on a prusa mk2. I don't believe the solution is in the printer profile, but I don't have enough experience to really know. 


Looking at the gcode, it's setting the right heights, just starting high for some reason.

Edited by 93levya

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use Privacy Policy