Jump to content
Ultimaker Community of 3D Printing Experts
jcw

Big blob at end of print, UM2+

Recommended Posts

Since a recent upgrade, I now always see each print end with a huge (3x3mm) blob driven into the object with the head remaining in the final position. Apart from the slight mess on the final print, this causes the filament-driving teeth to grind the plastic, so that the NEXT print fails to feed any material until I remove the PLA filament, cut off the ground piece, and re-insert it.

 

I've printed over 100 hours with this printer, it worked fine until the latest upgrade to fw 2.6.2, and works splendidly in every other respect. I'm using a new install of Cura 3.2.1 on macOS with a UM2+.

 

Is this a (known) bug in the latest firmware? Should I downgrade? And if so, to which version?

 

-jcw

 

PS. As a quick check, I just printed an object sliced by an earlier version of Cura, and that completed fine. So the problem may actually be in Cura, not the firmware... therefore, attached: an object which prints WITH the extra blob. Hopefully that will help someone diagnose this issue.

Extrudy_Object_2015_03_04_12_00_43.gcode

Edited by jcw

Share this post


Link to post
Share on other sites

Recently this problem was reported in the Cura 3.2 subject forum.

The problem is caused by a change in Cura which exposes a bug in the UM2(+) firmware: At the end of the gcode file, Cura used to save a few lines with the used Cura settings. These settings were removed making the file a few lines shorter and this exposes the bug where the UM2(+) finishes the print while still a few moves are in the motion controller buffer.

 

The bug will soon be fixed and consists of two changes:

1) We will fix the bug in the UM2(+)  firmware.

2) Cura will make the gcode files a bit longer again so the UM2(+) bug will not occur on older firmware versions.

 

For now the workaround is to revert to Cura v3.1. Or add about 10 extra comment lines at the end of your gcode file, or add an M400 command at the end of your gcode. These commands can be set in the 'End Gcode' section of your Cura machine settings.

 

Here a link with more info about the UM2 bug:

 

Edited by Indy31

Share this post


Link to post
Share on other sites

Hi!  I am also having this blob issue (I’m on a Mac, using Cura 3.2.1).  Could someone please tell me the exact code I would need to enter in the ‘End Gcode’ section of my Cura machine settings to fix things?  I would really appreciate the help - thanks!! :)

Share this post


Link to post
Share on other sites

Time has progressed....

Easiest solution right now is to download the Cura v3.3 beta release which should have the longer type of gcode files again and so hiding the UM2 bug. Note that the bug in the UM2 firmware has also been fixed but I didn't spend time in confirming it was included with this Cura beta version (there is a new firmware released with this Cura beta but it isn't mentioned in the release notes. It will sure be fixed and released in the final Cura 3.3 release).

 

Tip: You could even update your printer with the firmware from the Cura 3.3 beta and then revert to Cura v3.2 if you can't work with the beta.

Edited by Indy31
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!