Jump to content
Ultimaker Community of 3D Printing Experts

UM3 and Cura Connect video problem


EDTGprint
 Share

Recommended Posts

Posted · UM3 and Cura Connect video problem

Hello to everyone,

since a few days I own a UM3, so far working fine, but I'm having an problem with the built in camera, or better the software to access it.

Maybe the fault is the typical f40 (sitting 40cm in front of the computer).

UM3, firmware 4.3.2.20180308, connected to wifi, IP lets say 192.168.1.130 assigned via DHCP.

If I open 192.168.1.130 in a browser I get a connection to cura connect. But I will not get a live stream from the camera, neither on the print job page nor on the printer page, because as shown on the screenshot cura connect seems to use internal IP127.0.0.1. (localhost?)

5abd396d948ab_Screenshot-2018-3-29UltiprintCuraConnect.thumb.png.3d7d3565d21cbe0ace368175ee4bfd55.png

 

If I click on the camera icon on the print job page the popup for the video opens, but stays black.

The explore function of the firefox gives the following HTML phrase with the wrong IP as well.

<img class="video-stream" style="width: 600px; height: 450px;" src="http://127.0.0.1:8080/?action=stream">

 

Typing http://192.168.1.130:8080/?action=stream I get a stable video live stream.

 

Is this a wrong setup by me or a bug?

Thanks a lot for any help,

Tom

 

 

  • Link to post
    Share on other sites

    • 2 weeks later...
    Posted · UM3 and Cura Connect video problem

    No one an idea? I admit that delivering live video is not the main function of a 3D-printer.

    But if a webcam is built in, it should work in the designed way and not via a workaround only...

  • Link to post
    Share on other sites

    Posted · UM3 and Cura Connect video problem

     

    Sometimes the issue is due to mismatched settings between Cura and your machine. Try deleting your machine profile and adding it back in. This will be under Settings-->Printer-->Manage Printers. Once that is done you should be able to connect your machine again to confirm if the live stream is no available.

    If that doesn't work, try doing a Cura Connect Reset in the printer menu and/or hook it up via LAN to see if that changes anything.

    • Thanks 1
    Link to post
    Share on other sites

    Posted (edited) · UM3 and Cura Connect video problem

    Without logs, there is little we can do to help. So make a dump and post them here.

     

    That being said, i'm pretty sure that this has nothing to do with settings in Cura.

    Edited by nallath
  • Link to post
    Share on other sites

    Posted · UM3 and Cura Connect video problem

    Thank you very much Priddy,

    I had already deleted the machine profile and added it again several times.

    But the reset of the Cura Connect data in the printer itself solved the problem! Very helpful!

    @nallath: Thanks as well, but I have no idea how to make a dump, so I'll go back to the manual first. Still have a lot to learn about this machine ;)

    Regards, Tom

     

     

  • Link to post
    Share on other sites

    Posted · UM3 and Cura Connect video problem

    Your welcome! I'm glad to hear you were able to get it working.

     

    For future reference, your machine logs can be dumped to USB via System -> Maintenance -> Diagnostics -> Dump logs to USB. This page has details on where the Cura logs will be located on your computer: https://github.com/Ultimaker/Cura#logging-issues

     

    Have a great weekend!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...