Jump to content
Ultimaker Community of 3D Printing Experts

netfabb axis scaling


timmbos

Recommended Posts

Posted · netfabb axis scaling

Hello everyone,

because of my problems with connecting netfabb (4.8) to the Ultimaker [1] I am using the gcode export and print with ReplicatorG (24).

The problem is that the printed objects are twice as high as they should be and the slices are too big. If I want to print a cube I get a tower. If i set set the size to 20 x 20 x 10 (l x w x h) I get a cube (20 x 20 x 20).

I searched for an option to adjust the z-axis scaling (obviously it does two steps where it schould do one) but just can't find nothing.

When I use ReplicatorG standalone (with Skeinforge) the scaling is just fine. I am using the 5D firmware.

Do you have any suggestions?

Regards,

Timm

[1] http://forum.ultimaker.com/viewtopic.php?f=9&t=450

  • Link to post
    Share on other sites
    Posted · netfabb axis scaling

    I think there is a jumper to tell it to be 8 step and not 16 step or similar on the Arduino board which could be missing missing or there's an open circuit. Or it shouldn't be there and it is or there's a short. Someone who knows will chime in soon. Not sure why it's OK in Skienforge but there may be a software setting there for the 16 step.

  • Link to post
    Share on other sites
    Posted · netfabb axis scaling
    Thank you for your suggestion.

    The z stepper is set to 1/8 as explained in [1]. I allready thought about swiching to 1/16 to fix this but then it would be broken with ReplicatorG / Skeinforge an I hoped (and still hope) there is a software setting for this.

    [1] http://wiki.ultimaker.com/Electronics_build_guide

    It may be switched to 1/16 via a short, which is why double the steps are sent to the motor. If you had a multimeter you could measure it. If not you could look for a blob of solder accross the tracks. Another way to prove it is shorted is to see if there is a change when you do put a jumper there or not.

  • Link to post
    Share on other sites
    Posted · netfabb axis scaling

    My thought: Z feed rate.

    The Z might be controlled to fast and it's skipping steps. Slice something really small with both Skeinforge (RepG) and NetFabb, look at the differences in GCode. If the Z values are the same then it's possible that it's a Z feed rate issue. Your steppers might be underpowered in that case.

  • Link to post
    Share on other sites
    Posted · netfabb axis scaling

    owen: I checked with a multimeter for a short and there is none. I also printed with the jumper set (1/16). It was quite a mess (too much material flow of course).

    So I think this isn't the problem (I swiched back to 1/8) but I'm glad to have checked it.

    David: This is an interesting approach. I generated a 10x10x10 cube with Skeinforge and Netfabb and was suprised to find nearly equal z-values at the end of the file. So if there isn't a "scale" command in gcode (is there?) it has to be somthing like you suggested.I don't really see why the object would get higher by missing steps (maybe stopping to late?) but it's the best guess at the moment so I will power the stepper up a bit.

    By printing the 10x10x10 cube I found the the netfabb print has actually 2.2 times the height (10x10x22).

  • Link to post
    Share on other sites
    Posted · netfabb axis scaling

    While checking the stepper power I found that the heatsink of the z-axis driver was loose. It hung just on a tiny spot of thermal grease (glue).

  • Link to post
    Share on other sites
    Posted · netfabb axis scaling
    While checking the stepper power I found that the heatsink of the z-axis driver was loose. It hung just on a tiny spot of thermal grease (glue).

    The stepper driver will function fine without heatsink, its there to prevent any malfunctions when the fan shuts down.

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...