Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Question on connecting thermistor

Recommended Posts

Hello everyone,

after another jam I've reassembled the head of the printer and looks like pressed thermocouple cable too much. Can you please advice me on how to re-connect it? If I connect it touching to heater, it creates shortage and sparks, so printer does not turn on. If I just make it touch the metal part of the head, I think the readings are wrong because it heats too slow and temperature measurments are definetely wrongs (I tried touching it at 40 degrees....well that was not 40 degrees)

help much appreciated. Should I somehow put thermocouple cable into that golden plated circle (on the heater side)?

IMG 2579


Share this post

Link to post
Share on other sites

I'd recommend you get a replacement for that..

Be aware that this is not a thermistor but a thermocouple. You should get a replacement from UM, I don't think you'll find a perfect replacement elsewhere.

And don't turn it on again if it goes sparky on you! You might have to replace other things as well (like the thermocouple amplifier board if you shorted the heater's power path to the very low voltage thermocouple inputs). You can check the amp board for visual damage like burnt parts, but don't count on it...

Thinking about it, I can't really think of anything that would create sparks but the heater cartridge. The thermocouple generates it's own voltage (only about a millivolt) which is amplified on the amp board. Shorting a thermocouple results in nothing but getting a "zero" reading (might be your 40 degrees, I'm not sure about the details as I mostly worked on the hardware part, not the calculations). Are you sure the heater cartridge cables are ok? No burnt insulation?


Share this post

Link to post
Share on other sites

Thanks for correcting me. Not an expert in hardware. Well the thermocouple reads not only 40 degrees, it reads everything from room temperature till 220 or more. But It reads it wrongs, it heats too slow and I'm afraid when it reached 220 degrees (when I was preheating PLA), the real temperature was much higher, thats why the printer turned off. Unfortunately I cant get anything from UM because I'm from Russia. The thermocouple looked like this even before the issue, I've had a kapton tape around the head, I've detached it to make a photo. So I guess the kapton was the thing that connected thermocouple to what it should connect.

Everything on the amp board looks fine. So, any suggestions on how to reconnect it? I still believe it reads wrong temperature because I connected it wrong.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 16 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!