Jump to content
Ultimaker Community of 3D Printing Experts
bizilux

Trying to print my first design and it gets inverted inside out

Recommended Posts

Hey everyone...

 

I've designed this model in autodesk inventor, its supposed to be spiral wheel for marble machine. Its actually first model that i want to print that is my own design, so far I only printed from thingiverse. Anyways, im having issues.

 

here is how model should look. its a spiral, and  marble runs inside the "track", there's approximately 7 "tracks" until marble reaches the center, those tracks are divided by walls that are suppose to be 1.6mm wide... and in the center there's a hole so this wheel will be able to spin...

image.thumb.png.e8774f78a14fa01e7807ae31325c2c70.png

 

now in the layer preview view, problems start to arise. model generally looks okay, except for the very middle part where a hole is, that is all messed up.

image.thumb.png.898e1875442a2ee0baec8058c58af1a0.png

 

now real problems arise on top layers... it just kind of inverts everything, and it caps my "track", so it becomes a tunnel, which is not how i created this model

image.thumb.png.dca5d8d4424a401117d7d3794db1aa94.png

 

so what can i do? :/

I tried other profiles inside CURA, its always the same, model gets inverted inside out... did i model it incorrectly or what?

one thing i had to do was scale model 1000%, because for some reason its 10x smaller than in inventor, i  need to figure this out, but i dont think it should impact what is happening here?

Share this post


Link to post
Share on other sites
6 hours ago, bizilux said:

did i model it incorrectly or what?

 

Yes, probably. Can you check the model in X-Ray view? If there are red areas in X-Ray view, your model has "internal geometry", and Cura looses count what is inside and what is outside.

 

Care to share the STL file?

 

Note that STL files do not contain units, so Cura can only make an assumption to the unit that was used while modeling. Since Cura can't read your mind, it always assumes the unit is MM (and you probably modeled in CM if you have to scale the model up to 1000%).

  • Like 1

Share this post


Link to post
Share on other sites

I fixed it, thanks Ahoeben

 

"Union Overlapping Volumes"  did not help with the model i had, but once i modified the model, turning that settings off did help. otherwise it would just cap the model.

 

so what was wrong?  by trial and error i found out..

 

when i went to thicken the walls by 1.6mm in autodesk inventor, there are settings for "in which way" do you want to thicken them.

image.png.838d5a262f63cd9a4e510d3284b34524.png

this is how it looks in inventor:

image.thumb.png.a49341f6ce2a4dec3c841a8f22ce1ab2.png

 

when its in the setting to thicken in both ways, that works like it should and model slices nicely, but before i had it to thicken just outwards (middle button of the 3) and this is how it looks in inventor then:

image.thumb.png.7d2f72666136e5be11c2fea39c052ff3.png

notice the red walls all of a sudden, that was probably the problem. I dont know what red walls stand for, im quite new in inventor... my bet is that they stand for normals of faces not facing outwards like in top picture?

 

so yes, finished model looks nicely now.. marble will run inside these tracks... i do have one other issue tho... walls appear to be low resolution... like the circle is made out of 40 faces/polygons instead of 200 faces/polygons... its not smooth, you can see how i've drawn blue lines next to visible faces/polygons.   you can see in inventor screenshot how smooth the model is, but when its in CURA, the circle becomes quite blocky... i suppose theres a settings for that in cura

image.thumb.png.877cbcf5bb2055a36e938af882c3534e.png

 

Share this post


Link to post
Share on other sites
3 hours ago, bizilux said:

 i suppose theres a settings for that in cura 

 

No, this needs to be fixed in inventor too. When exporting, your perfectly round cylindrical walls get converted into polygons. Polygons (triangles) have no curves; polygons can only approximate a curve. By the time the model is loaded into Cura, there are no curves, only polygons.

 

The more polygons are created, the more precise the approximation of the curve. Somewhere in inventor, there has to be a setting for the precision of exported models.

Edited by ahoeben
  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!