Jump to content
Ultimaker Community of 3D Printing Experts

Disable Second Extruder, Prime Tower Settings, Won't Print


AbeFM
 Share

Recommended Posts

Posted · Disable Second Extruder, Prime Tower Settings, Won't Print

Going back at least to 3.5.1:

 

When you disable the second extruder, many changes are made automatically, one of them is setting the Prime Tower X and Prime Tower Y coordinates to 0.

 

Even with the prime tower turned off, this triggers an error, and won't slice due to "per model settings".

 

image.png.b7f9e5dc7b9e256d22aeedf293a97d2e.png

 

Two problems:

1) Prime Tower Position is NOT a per-model setting

2) There's no reason not to slice due to poor positioning of something you're not using.

 

I suggest removing the tower position as a "per model settings check".

I suggest tweaking the check to something like " && !(prime_Tower_Is_Enabled?)

 

Or if I'm doing something wrong, let me know. Currently I just set standby temp to 0 (preventing extrusions but not travels), or add another printer with one nozzle and try to keep them concurrent.

  • Link to post
    Share on other sites

    Posted · Disable Second Extruder, Prime Tower Settings, Won't Print

    I'm having some trouble reproducing this. If I disable an extruder, it never tries to change the prime_tower_enabled setting.

    Could you share your exact reproduction steps?

  • Link to post
    Share on other sites

    Posted · Disable Second Extruder, Prime Tower Settings, Won't Print

    Ok.

    Install CURA fresh. Allow it to delete old profiles. I added ONLY a generic printer, set for 2 extruders. Use, verify functionality, quit CURA (done in the "before time"). Perhaps yours doesn't do this because you've installed an UM profile in your CURA? (I didn't test that)

     

    To answer this post, I:

    Load CURA 3.6.0

    Right click, Disable second extruder

     

    This notice, similar to but out of order from the lower notice shown in previous post appears.:

    image.png.2649b951e2fe4d572fffe1679d65464d.png

     

    Not hard to reproduce on my end! No model, no nothing.

     

    It seems to happen with Prime Tower enabled or disabled. The option always comes back on regardless of previous state when I enable the extruder.

     

  • Link to post
    Share on other sites

    Posted · Disable Second Extruder, Prime Tower Settings, Won't Print

    Even with your reproduction steps, I still can't reproduce it. I've tried it with a clean install and using the build that we provided, but still no luck. 

  • Link to post
    Share on other sites

    Posted · Disable Second Extruder, Prime Tower Settings, Won't Print

    Hmmm, at an impasse then. 

     

    Is there something I could do to help you see it happening in a way that would help?

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...