Jump to content
Ultimaker Community of 3D Printing Experts

Dual Extrusion Kit, 2nd Extruder and Nozzle Non-Functional


Recommended Posts

Posted · Dual Extrusion Kit, 2nd Extruder and Nozzle Non-Functional

The 2nd extrusion system on my Ultimaker is apparently not being recognized in Cura 13.06.4 (Windows). The printer previously worked without issue, and after upgrading for dual extrusion the 1st extruder and nozzle continue to function, but not the 2nd extruder.

Furthermore, I do not see any options in Cura for selecting which nozzle to use for a given part placed into Cura (For example, in Cura 13.03 I could select a part for a different extruder, and it would show up with the different color. This is how I knew which nozzle was used for a given color of PLA).

Some of the things I have tried, but to no avail:

-closing out & restarting Cura

-closing out & restarting Windows

-complete uninstall & reinstall of both previous versions of Cura and the latest

-reinstalling the Marlin firmware, latest (v1)

-verified that no voltage is being applied to the 2nd heater block with a multimeter, but voltage (heat) is being applied to the 1st heater block

-verified that all connections correct per install instructions

-tried making a test print using Cura's option with 2nd extruder as support (Support dual extrusion); instead BOTH support and the part materials come from the first nozzle.

Please help! Thanks!

 

  • Link to post
    Share on other sites
    Posted · Dual Extrusion Kit, 2nd Extruder and Nozzle Non-Functional

    Hi Jim,

    When I installed my second extruder I had the same issue. I had to manually rebuild marlin with #EXTRUDER_COUNT set to 2 in configuration.h.

    I don't think this is documented, but it should be.

    Regards,

    Troy.

     

  • Link to post
    Share on other sites
    Posted · Dual Extrusion Kit, 2nd Extruder and Nozzle Non-Functional

    I set Cura to use dual-extrusion in the preferences menu, but I did not use the first-run wizard or re-load the cura firmware was I have a custom heated bed so I use my own build of Marlin that was originally generated with the Daid Marlin builder.

    When I first installed the second extruder I tried both NetFabb and Cura and was unable to get the machine to respond to any commands for the second extruder. Setting it's temp didn't do anything and it always returned 0 as the temperature. I connected on Pronterface and tried sending a T1 command to it, which returned a message saying that 1 was an invalid extruder number. Anything for extruder 0 worked, but extruder 1 returned an error.

    So I took a look in the Marlin configuration.h and found this:

     

    // This defines the number of extruders

    #define EXTRUDERS 1

     

    Changing that to 2 and rebuilding marlin got everything working just fine.

     

    Cheers,

    Troy.

     

  • Link to post
    Share on other sites
    Posted · Dual Extrusion Kit, 2nd Extruder and Nozzle Non-Functional

    Thanks for the feedback. It seems simply updating the firmware through Cura was all that was needed to get dual extrusion working. Printed the robot ice .amf file and it came out great!

    However, have not found any option for choosing the second color for another part. Instead the only thing that seems to work is the dual extrusion merge. What if someone does not want to merge the parts, but simply print something else onto the bed with a different color? A previous version of Cura seemed to allow that.

    I have tried using the AMF Tools software to create a dual extrusion file (it seems this is what would be used for creating a file like RoboIce-dual.amf), but when it is uploaded into Cura the second color does not show up. That said, how did you make the RobotIce-dual.amf file to allow Cura to acknowledge the 2nd color material?

    Cheers

     

  • Link to post
    Share on other sites
    Posted · Dual Extrusion Kit, 2nd Extruder and Nozzle Non-Functional

    The AMF files for dual extrusion can be saved from Cura after a dual-extrusion merge.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...