Jump to content
Ultimaker Community of 3D Printing Experts

Integration with Fusion360 on Windows10


mogul
 Share

Recommended Posts

Posted (edited) · Integration with Fusion360 on Windows10

I am trying to setup a workflow to easily print multiple components/bodies designed in Fusion360, say a bolt and a nut. 

In Fusion360 I start by hitting "make"  and select the bolt. This opens cura with the bolt ready to print. Then I go on and "make" the nut as well. This sends the nut stl to cura but unfortunately at the same time cura discards the bolt already there.

I can go the long way around, exporting both nut and bolt to files, and then in cura load these two files. But since the integration is almost there it would be nice not to have to worry about files at all.

 

I am on a windows10 for this, both Fusion360 and cura are freshly updated.

Currently I have a small batch script to start cura. This script adds the --single-instance option to the cura start up. Otherwise I get a new cura window for every print I am going to make.

I guess there might be several more command line options to feed to cura, eventually one of them is "--do-not-empty-build-plate" or what ever it might be called. Are these documented somewhere?

 

Edited by mogul
  • Link to post
    Share on other sites

    Posted · Integration with Fusion360 on Windows10

    This is strange why it is not working for you out of the box. I am on a Mac but I do exactly what you did and have both parts on the plate without any switches.

     

    I am not sure at the moment if there is an option in Cura preference which clears the plate and could cause this behavior but I assume no.

     

    Is Fusion calling the batch or the exe file? Can you try if this makes any difference?

  • Link to post
    Share on other sites

    Posted (edited) · Integration with Fusion360 on Windows10
    58 minutes ago, Smithy said:

    Is Fusion calling the batch or the exe file? Can you try if this makes any difference?

     

    If I let fusion call the cura.exe file directly, I get a new cura instance for every make. If is use my batch file, with --single-instance, I get to reuse the running cura, but the build plate is cleared.

    I think the mac I use in the office does do it the "right" way, like yours as well. This might be a windows only problem. (I have just updated the thread topic to indicate this)

    Edited by mogul
  • Link to post
    Share on other sites

    Posted (edited) · Integration with Fusion360 on Windows10
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...