Jump to content
mogul

Integration with Fusion360 on Windows10

Recommended Posts

Posted (edited) · Integration with Fusion360 on Windows10

I am trying to setup a workflow to easily print multiple components/bodies designed in Fusion360, say a bolt and a nut. 

In Fusion360 I start by hitting "make"  and select the bolt. This opens cura with the bolt ready to print. Then I go on and "make" the nut as well. This sends the nut stl to cura but unfortunately at the same time cura discards the bolt already there.

I can go the long way around, exporting both nut and bolt to files, and then in cura load these two files. But since the integration is almost there it would be nice not to have to worry about files at all.

 

I am on a windows10 for this, both Fusion360 and cura are freshly updated.

Currently I have a small batch script to start cura. This script adds the --single-instance option to the cura start up. Otherwise I get a new cura window for every print I am going to make.

I guess there might be several more command line options to feed to cura, eventually one of them is "--do-not-empty-build-plate" or what ever it might be called. Are these documented somewhere?

 

Edited by mogul

Share this post


Link to post
Share on other sites
Posted · Integration with Fusion360 on Windows10

This is strange why it is not working for you out of the box. I am on a Mac but I do exactly what you did and have both parts on the plate without any switches.

 

I am not sure at the moment if there is an option in Cura preference which clears the plate and could cause this behavior but I assume no.

 

Is Fusion calling the batch or the exe file? Can you try if this makes any difference?

Share this post


Link to post
Share on other sites
Posted (edited) · Integration with Fusion360 on Windows10
58 minutes ago, Smithy said:

Is Fusion calling the batch or the exe file? Can you try if this makes any difference?

 

If I let fusion call the cura.exe file directly, I get a new cura instance for every make. If is use my batch file, with --single-instance, I get to reuse the running cura, but the build plate is cleared.

I think the mac I use in the office does do it the "right" way, like yours as well. This might be a windows only problem. (I have just updated the thread topic to indicate this)

Edited by mogul

Share this post


Link to post
Share on other sites
Posted · Integration with Fusion360 on Windows10

Yes, I think we have to wait for an answer from a windows user.

Share this post


Link to post
Share on other sites
Posted (edited) · Integration with Fusion360 on Windows10

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!