Jump to content
UltiMaker Community of 3D Printing Experts

Connecting Cura 4.4.1 with Octoprint


lela
 Share

Recommended Posts

Posted · Connecting Cura 4.4.1 with Octoprint

Hello.
Is it possible to get help connecting Cura 4.4.1 with Octoprint.
In the marketplace, it says that octoprint is installed.
But I can't get the field where the API key needs to be entered.
I can't delete or update Octoprint in the marketplace.
Is anyone here to help with this?
Thanks in advance
Leif.

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    Hi Leif, what printer and what OS do you use?

     

    if you go to the “Printers” pane of the Preferences, is there a “Connect to OctoPrint” button?

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint
    40 minutes ago, ahoeben said:

    Connect to OctoPrint

    It is a CR-10S Pro and windows 10
    and I don't have the Connect to OctoPrint button.
    Thank you in advance for your help
    and Merry Christmas.

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    Hi @ahoeben, I noticed with my latest Cura builds that the OctoPrint plugin didn't load because the netifaces module wasn't getting included in the cx_freeze. I had to explicitly add it to the list of modules to include. Maybe relevant?

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    @Lela, how did you add your printer to Cura? Are you sure you didn’t add it as an *Ultimaker* S5 instead of a Creality machine? The Ultimaker S5 is not compatible with OctoPrint so the button is not shown.

     

    If you added it as a creality machine, then please post a link to your Cura.log. It can be found via Help -> Show configuration folder.

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    Yes I am sure I have chosen "Creality CR-10S Pro".
    I have attached the cura.log file, but it looks very complicated to me 🙂

     

    cura.log

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    The plugin is not loading because you have installed a version that has not yet been thoroughly tested in the program files bundle. Please remove that, and also check if there are any OctoPrintPlugin folders in your Configuration Folder (Help -> Show configuration folder -> plugins). Then please reinstall the plugin from the Marketplace.

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    When I installed Cura 4.4.1 I chose to uninstall Cura 4.0. But it did not uninstall the configuration directory, it helped when I did it manually and reinstalled Cure 4.4.1 again.
    Many thanks for the help. 🙂

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    @lela, so you got it working again?

     

    @burtoogle, are you installing the plugin through the Marketplace, or including the latest version from git? I can see how using the git version could have that netifaces issue (thanks for pointing that out), but not the version on the Marketplace.

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    Yes, it works now  🙂

    • Like 1
    Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint
    5 hours ago, ahoeben said:

    @burtoogle, are you installing the plugin through the Marketplace, or including the latest version from git? I can see how using the git version could have that netifaces issue (thanks for pointing that out), but not the version on the Marketplace.

     

    Merry Christmas Aldo. I saw that problem using my master branches for Cura/Uranium, cura-build-environment and cura-build. The plugin was the version that the marketplace installs.

    • Like 1
    Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    Merry Christmas to you too. Why are we on our computers?

  • Link to post
    Share on other sites

    Posted · Connecting Cura 4.4.1 with Octoprint

    cura version 4.6 have a Octoprint plugin. You can get it from the marketplace,

     

    I had a problem that cura would not keep the Apikey needed until i added the printer again.

     

    Best regards Jørn Johanesson

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...