Jump to content
Ultimaker Community of 3D Printing Experts

Erhebliche Probleme mit Cura 4.4.X


Andygraphy
 Share

Recommended Posts

Posted · Erhebliche Probleme mit Cura 4.4.X

Hallo zusammen,

 

nach längerer Zeit wollte ich mal wieder meinen UM2 mit Olsson Block in Betrieb nehmen. Da ich ein komplett neues Filament nun probieren wollte, hatte ich vor ein Temperature Tower Test zu machen... Da viel mir auf das ich noch Cura 2.3.x installiert hatte, welches keinen G-Code Editor besitzt.... Also schnell auf die Ultimaker HP und Cura 4.4.1 geladen.... da dies zickte habe ich 4.4.0 nun installiert was genau das gleiche macht.

 

Also folgendes... Bei den Settings, kann man wie im Bild sehen, dass in den Einstellungen viel mehr Optionen auf Sichtbar gestellt sind... aber Rechts ändert sich nichts. Das müsste doch deckungsgleich sein!? Auf youtube sieht man bei anderen Usern auch das sich bei der Auswahl in der Einstellung, das jeweilige Feature direkt in der Auswahlliste rechts einordnet. Bei mir regt sich da gar nichts.

1461690058_Bildschirmfoto2020-01-18um21_51_42.thumb.png.8833c955917a389e3392f230e1765215.png

 

Und noch ein weiteres Problem... Wenn ich unter Einstellung auf "Material" gehe.. sollten da ja eigentlich schon vordefinierte Materialien sein...zumindest welche von Ultimaker selbst... meine Liste ist aber leer. Und auch komplett eigene Filamente kann ich nicht Erstellen. Wenn ich auf "Erstellen" klicke...tut sich einfach gar nichts. Auch bis auf Preis/Gewicht kann ich nichts eingeben.

1924238220_Bildschirmfoto2020-01-18um22_12_29.thumb.png.fa6da2e5a7b10644ef2874a9d08df300.png

 

Weiß jemand was da bei mir Falsch läuft?

 

VG

Andy

 

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    16 hours ago, Andygraphy said:

    Da viel mir auf das ich noch Cura 2.3.x installiert hatte, welches keinen G-Code Editor besitzt.

     

    Erstmal eine Frage dazu: was meinst Du mit "G-Code Editor" und wo findet man den in Cura 4.x?

    Oder meinst Du Start- und Stop-Skripte?

     

    16 hours ago, Andygraphy said:

    nach längerer Zeit wollte ich mal wieder meinen UM2 mit Olsson Block in Betrieb nehmen.

     

    Am UM2 werden standardmäßig alle Material-Einstellungen am Drucker verwaltet (Du erinnerst Dich vielleicht noch... 😊).

    Nur wenn in den (Cura-) "machine settings" der GCode-Flavor auf "Marlin" umgestellt wird, übernimmt Cura diese Aufgabe. Dann werden die entsprechenden Optionen in Cura  eingeblendet und der generierte gcode ignoriert das ausgewählte Material vom Drucker.

     

    • Like 1
    Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X

    Hi,

    also mit dem G-Code Editor meinte ich die Option "Modify G-Code" unter den Erweiterungen. Dieses fehlte mir schlcihtweg bei der damaligen Version.

     

    Hm wie meinst du das jetzt nochmal genau? 🙂 Habe gerade bei mir in Cura unter den Geräteeinstellungen geschaut und dort steht unter der G-Code Einstellung "ultimaker 2" . Was ist den der Unterschied zwischen "Marlin" und "Ultimaker 2"?

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    On 1/19/2020 at 3:33 PM, Andygraphy said:

    Was ist den der Unterschied zwischen "Marlin" und "Ultimaker 2"?

     

    Mit "Ultimaker 2" wird am Anfang der Gcode-Datei ein spezieller "UltiGCode"-Kommentar eingefügt, aber keinerlei Material-spezifischen Befehle generiert (z.B. Temperaturen oder Retract-Länge). Es werden dann (wie in den guten alten Zeiten) die Einstellungen verwendet, die im Material-Menü am Drucker vorgenommen wurden (dieses Feature gibt es nur beim UM2 und UM2+). Konsequenterweise sind die Materialeinstellungen in Cura dann ausgeblendet.

    Mit den Material-Profilen in Cura arbeite ich nicht, aber ich vermute, das hat die gleiche Ursache.

     

    Ist "Marlin" eingestellt ist es genau umgekehrt. Alle Material-Einstellungen werden in Cura konfiguriert und die im Drucker festgelegten Werte werden ignoriert.

    Beim Drucken von sd-Karte gibt es am Drucker dann auch noch eine entsprechende Meldung, die man erst bestätigen muss, bevor der Druck gestartet wird (daran gewöhnt man sich...).

     

    In Cura gibt es inzwischen deutlich umfangreichere Optionen, als damals am Drucker möglich war. Deswegen ist letzteres heutzutage zu bevorzugen (meiner Meinung nach). Möglich ist aber nach wie vor beides.

     

  • Link to post
    Share on other sites

    Posted (edited) · Erhebliche Probleme mit Cura 4.4.X

    Ah super! Das erklärt dann so einiges! 

    Nun kann ich auch endlich alle Settings auswählen 🙂

     

    Edit: Jetzt verstehe ich auch das ich auf dem Ultimaker die Firmware auf Marlin wechseln muss!? Da habe ich aber direkt eine weitere Frage...ich habe nämlich bereits die Tinker Firmware drauf da ich einen Bondtech Extruder betreibe..... funktioniert dieser auch mit der Marlin Fw? Und wie Stelle ich diesen dann ein?

    Edited by Andygraphy
  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X

    Du musst am Drucker selbst nichts ändern. Ultimaker 2 bzw. Marlin ist keine Firmware, nur eine Einstellung in Cura wie der GCode generiert werden soll.

     

    D.h. einfach in Cura umstellen und losdrucken. Geht natürlich auch mit der Ticker FW.

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    5 minutes ago, Smithy said:

    Du musst am Drucker selbst nichts ändern. Ultimaker 2 bzw. Marlin ist keine Firmware, nur eine Einstellung in Cura wie der GCode generiert werden soll.

     

    D.h. einfach in Cura umstellen und losdrucken. Geht natürlich auch mit der Ticker FW.

     Hmmm ok!? Das hatte ich vorhin versucht. Wie beschrieben kam dann die Info zur Bestätigung das die Einstellungen nicht vom Drucker kommen... Dann hat der die Achsen nach der Aufwärmphase kurz zwei mal gegen den Endschalter gefahren und den Fehler rausgeworfen das der Druck außerhalb des Druckbereiches liegt...

     

    Find ich schon etwas komisch.

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X

    Ja das ist komisch.

    Und du hast nur im Drucker Profil in Cura den G-code Flavor auf Marlin gewechselt?

     

    image.thumb.png.b7bbbd9f50461c28b8eefddf5ebd5609.png

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    2 hours ago, Andygraphy said:

    und den Fehler rausgeworfen das der Druck außerhalb des Druckbereiches liegt

     

    Zuerst mal: die Firmware im Drucker ist Marlin (mit einem Ultimaker-Menü obendrauf und der genannten "UltiGCode"-Erweiterung).

     

    Wegen der Fehlermeldung: es kommt ein bisschen darauf an, welche Firmware-Version drauf ist (war die von Bondtech bereitgestellt oder eine andere?). Die Tinker-Firmware hatte in 2016 vorübergehend eine minimale Y-Koordinate von 5 festgelegt. Daher kommt es wahrscheinlich.

    Die Startposition im (standardmässigen) Cura-Startskript weicht auch ein bisschen vom "UltiGCode"-Modus ab. Beides zusammen verhindert grade den Erfolg... 🙂

     

    UM2_startscript.thumb.png.a00f2813d349ede510d5c8c9c8639cac.png

     

    Wenn Du in der markierten Zeile die X-/Y-Koordinaten auf die "normalen" Werte änderst, dann passt es wieder:

    G1 X5 Y10 ....

     

    Oder tausche einfach den kompletten Start G-Code hiermit aus, da hab ich es schon eingetragen:

     

    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 Z0 ;move Z to bottom endstops
    G28 X0 Y0 ;move X/Y to endstops
    G0 X5 Y10 F6000 ;move X/Y to front of printer
    G0 Z20.0 F2400 ;move the platform to 20mm
    M190 S{material_bed_temperature_layer_0}
    M109 S{material_print_temperature_layer_0}
    G92 E0 ;zero the extruded length
    G1 F200 E20 ;revert end-of-print retraction
    G1 F60 E25 ;extrude 5 mm of feed stock
    G92 E0 ;zero the extruded length again
    G1 F9000
    ;Put printing message on LCD screen
    M117 Printing...

     

    • Like 1
    Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    18 hours ago, tinkergnome said:

     

    Zuerst mal: die Firmware im Drucker ist Marlin (mit einem Ultimaker-Menü obendrauf und der genannten "UltiGCode"-Erweiterung).

     

    Wegen der Fehlermeldung: es kommt ein bisschen darauf an, welche Firmware-Version drauf ist (war die von Bondtech bereitgestellt oder eine andere?). Die Tinker-Firmware hatte in 2016 vorübergehend eine minimale Y-Koordinate von 5 festgelegt. Daher kommt es wahrscheinlich.

    Die Startposition im (standardmässigen) Cura-Startskript weicht auch ein bisschen vom "UltiGCode"-Modus ab. Beides zusammen verhindert grade den Erfolg... 🙂

     

    UM2_startscript.thumb.png.a00f2813d349ede510d5c8c9c8639cac.png

     

    Wenn Du in der markierten Zeile die X-/Y-Koordinaten auf die "normalen" Werte änderst, dann passt es wieder:

    G1 X5 Y10 ....

     

    Oder tausche einfach den kompletten Start G-Code hiermit aus, da hab ich es schon eingetragen:

     

    
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 Z0 ;move Z to bottom endstops
    G28 X0 Y0 ;move X/Y to endstops
    G0 X5 Y10 F6000 ;move X/Y to front of printer
    G0 Z20.0 F2400 ;move the platform to 20mm
    M190 S{material_bed_temperature_layer_0}
    M109 S{material_print_temperature_layer_0}
    G92 E0 ;zero the extruded length
    G1 F200 E20 ;revert end-of-print retraction
    G1 F60 E25 ;extrude 5 mm of feed stock
    G92 E0 ;zero the extruded length again
    G1 F9000
    ;Put printing message on LCD screen
    M117 Printing...

     

     Ich seid echt der Wahnsinn! vielen lieben Dank! 🙂  Nun läuft der Ultimaker wieder wie vorher! Trotz Marlin Einstellung!

     

    Ich habe da noch ne andere kleine Frage.. und zwar lässt sich bei mir nur eine Einzugsgeschwindigkeit von max 45mm/s einstellen. danach wirft er folgenden Fehler raus und will nicht Slicen. Wisst ihr vielleicht warum? und wie ich das umgehen kann? Hab leider trotz 45mm/s und guten 8-10mm Einzug immer noch Stringing 😕 

     

    Bildschirmfoto 2020-01-19 um 19.27.06.png

    WhatsApp Image 2020-01-19 at 19.24.13.jpeg

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    5 hours ago, Andygraphy said:

    Ich habe da noch ne andere kleine Frage.. und zwar lässt sich bei mir nur eine Einzugsgeschwindigkeit von max 45mm/s einstellen. danach wirft er folgenden Fehler raus und will nicht Slicen. Wisst ihr vielleicht warum? und wie ich das umgehen kann? Hab leider trotz 45mm/s und guten 8-10mm Einzug immer noch Stringing 😕 

     

    45mm/s ist das Maximum bei Ultimaker-Druckern. Selbst wenn Cura höhere Werte zulassen würde, begrenzt es die Firmware später doch wieder auf 45mm/s.

     

    Ich glaube, das ist in diesem Fall auch gar nicht das Problem. Stell das lieber wieder zurück auf den Standard, die 6,5mm bei 25mm/s reichen vollkommen aus. Ist das eigentlich PLA oder irgendwas exotischeres?

     

    Es vermute eher, das bei diesen kleinen Teilen irgendwann gar keine Retractions mehr ausgeführt werden, weil der "maximum retraction count" erreicht ist. Achte einfach mal drauf, ob das markante "beep-beep" überhaupt in jedem Layer stattfindet.

    Dann wären das hier eher die Kandidaten für einen näheren Blick:

     

    max_retract_count.png.31dfcd7806af6014c3e0b15519621b70.png

     

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    32 minutes ago, tinkergnome said:

    Es vermute eher, das bei diesen kleinen Teilen irgendwann gar keine Retractions mehr ausgeführt werden, weil der "maximum retraction count" erreicht ist.

     

    P.S. - das würde man allerdings auch schon in der Druckvorschau sehen - hier etwas übertrieben: die blauen Linien sind Bewegungen ohne Retraction.

     

    Hast Du am "Combing Mode" irgendetwas geändert (ich glaube in der deutschen Übersetzung heißt es irgendwas mit "Kamm" oder so ähnlich)?

     

     

    cura_travel.thumb.png.a6db46b5b31eb086d6c08d156eb9a015.png

  • Link to post
    Share on other sites

    Posted · Erhebliche Probleme mit Cura 4.4.X
    19 hours ago, tinkergnome said:

     

    P.S. - das würde man allerdings auch schon in der Druckvorschau sehen - hier etwas übertrieben: die blauen Linien sind Bewegungen ohne Retraction.

     

    Hast Du am "Combing Mode" irgendetwas geändert (ich glaube in der deutschen Übersetzung heißt es irgendwas mit "Kamm" oder so ähnlich)?

     

     

    cura_travel.thumb.png.a6db46b5b31eb086d6c08d156eb9a015.png

    Hmm also in der Druckvorschau kann ich kaum was erkennen bei mir...

     

    bezüglich Combing Mode habe ich nichts dran geändert oder je was dran getan.

    Ich habe mal die funktion "Coasting" aktiviert.. das Ergebnis war schon um einiges besser... aber immer noch nicht akzeptabel

    Bildschirmfoto 2020-01-23 um 18.43.18.png

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...