Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
petermeuris

reset firmware?

Recommended Posts

Hello all,

I was trying out some new firmware, and I am stuck.

I was able to work with replicatorG and the motors do work, no heating nor extrusion.

Then I tried out some newer firmware, but now I cannot connect anymore.

It says:

Attempting to reset RepRap (pulsing RTS)

Unknown: **********HERE SOME STRANGE SYMBOLS

Any help ?

Thanks,

Peter

Share this post


Link to post
Share on other sites

The firmware from:

http://daid.eu/~daid/marlin_build/

is recommended.

But if you want to print from RepG you need to:

-Set the baudrate to 57600

-Disable the "software endstops"

-"Steps per unit" for "E" needs to be 14 with the RepG from Ultimaker.

Or, you could upgrade to the SkeinPyPy Beta3:

https://github.com/daid/SkeinPyPy/downloads

Which helps you installing the right firmware, and allows faster and better slicing.

Share this post


Link to post
Share on other sites

The first link I gave you can build a firmware for you, it also contains a batch file that helps you in changing the firmware, this always works, even if RepG cannot connect.

The settings I said you need to change in the link I gave.

Share this post


Link to post
Share on other sites

Hey Daid,

 

The firmware from:

http://daid.eu/~daid/marlin_build/

is recommended.

But if you want to print from RepG you need to:

-Set the baudrate to 57600

 

I have it set to 115200, it works fine.

 

The firmware from:

http://daid.eu/~daid/marlin_build/

is recommended.

But if you want to print from RepG you need to:

-Disable the "software endstops"

-"Steps per unit" for "E" needs to be 14 with the RepG from Ultimaker.

 

I have my software stops enabled, is that because I use Netfab?

I thought the E14 was only for Netfab.

Hi petermeuris

Use Daid's link you configure and upload your firmware from there.

You configure it, download the zip file, run the batch file, enter your com port, ie. COM4 and it does the rest.

It's great and so is that version of Marlin.

Share this post


Link to post
Share on other sites

So I followed your first link, created the software uploaded it, but is tells me:

avrdude: stk500v2_ReceiveMessage(): timeout

avrdude: stk500v2_ReceiveMessage(): timeout

avrdude: stk500v2_ReceiveMessage(): timeout

avrdude: stk500v2_ReceiveMessage(): timeout

EDIT: Restarted the ultimaker and ran the uploader again, this uploads the software

And I can connect again with repG !

Thanks !!

Still no heating nor movement in the feeding motor though, the rest works.

So I have still work to do :-)

Share this post


Link to post
Share on other sites

The extruder (feeder) motor won't move unless it's on proper temperature (cold extrusion prevention)

However, in RepG26 the direct control of the extruder is broken, so you cannot use that to test the extruder. Heating should work however. Be careful, it can be the heater, or the sensor that's not working. If the temperature sensing is not working then you could damage your machine!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!