Jump to content

First layer of file from Cura is printing too high


jjcschmidt

Recommended Posts

Posted · First layer of file from Cura is printing too high

I am having difficulty printing from all Cura files. They all print too high on the z axis.  I am using  Creality Ender 3 for printing.  Any suggestions on how to fix this? (I am new to 3D printing.)

  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    There is a setting in Cura under "Quality" called "Initial Layer Height".  It sets the height for Layer 1 and I think the default is .28mm.  It does not change automatically when you change the regular layer height.

    If the setting isn't visible, slide the cursor across the Quality bar and click on the gear icon.  Then check the box for Initial Layer Height.

  • Link to post
    Share on other sites

    • 2 months later...
    Posted · First layer of file from Cura is printing too high

    I was having the pretty much the exact same issue, Ender 3 - Cura 4.7. My initial layer height was set to .2mm, what ended up working for me was installing the z offset plugin from the cura marketplace, setting that to -0.1 and setting initial flow to %115. Gave me a good first layer with solid adhesion, didn't have to mess with the gcode or anything else. 

    • Like 1
    Link to post
    Share on other sites

    • 3 months later...
    Posted · First layer of file from Cura is printing too high

    I can confirm that this bug is still present in the latest version of Cura. The piece of paper levelling system is irrelevant as the Cura generated G-code appears to fail to reset Z to 0 after the nozzle cleaning lines. The only work around I have for this so far, is to quickly reset the Z offset on the printer at the start of each print. 

    • Like 1
    Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    I have the exact same problem with my Ender 3 Pro.

     

    Here is my gcode :)

     

    ...
    ;Generated with Cura_SteamEngine 4.8.0
    M140 S65
    M105
    M190 S65
    M104 S210
    M105
    M109 S210
    M82 ;absolute extrusion mode
    ; Ender 3 Custom Start G-code
    G92 E0 ; Reset Extruder
    G28 ; Home all axes
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
    G92 E0
    G92 E0
    G1 F1500 E-6.5
    ;LAYER_COUNT:508
    ;LAYER:0
    M107
    G0 F6000 X75.651 Y108.659 Z0.12
    ;TYPE:SKIRT
    G1 F1500 E0
    G1 F1200 X76.119 Y108.368 E0.011
    G1 X76.624 Y108.147 E0.022
    ...

     

  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    You have to remember that Cura doesn't know where the build plate is.  It can only act on the settings.  The printer determines the first layer height through your leveling because it is you (or the ABL) that tells the printer "OK, you're at zero now".  You need to either adjust the ABL system or practice getting the feel of the piece of paper.

     

    That is the standard start code for an Ender 3 Pro.  (It was developed by "trouch.com" and submitted to Ultimaker for inclusion in Cura).  I can see that your retraction is set to 6.5 and your initial Layer Height is 0.12.

    The purge lines are 0.3 high and at a very heavy flow rate.  That is as it should be.  When the actual print starts the line

    G0 F6000 X75.651 Y108.659 Z0.12 tells the printer to move to the XY start point at a height of 0.12. Then there is a prime to E0 from E-6.5 and then the extrusions start with the print head at Z0.12.  THAT DOES NOT MEAN THAT THE PRINT HEAD IS 0.12 FROM THE PLATE.  It only means that it is 0.12 above Z0 and you told the printer where Z0 was.

     

    If the purge lines aren't printing correctly then change the four Z0.3 values to Z0.24. 

  • Link to post
    Share on other sites

    Posted (edited) · First layer of file from Cura is printing too high

    I try with the Z Offset plugin (-0.2mm for me) and it seems to work for the moment. I will let you know if it solves the issue.

     

    EDIT: Works fine with the offset 🙂

    Edited by ConanGuy
  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    I guess the plugin is one way to go.  There are others.

    You could alter your Home Offset Z in the printer.

    You could adjust the Z offset in the printer ABL configuration (if you have one).

    You can push the Initial Layer Flow to 120% or something like that.

     

    It's all about getting that first layer down.  I started out by kicking the initial layer flow up.  I knew it was a crutch, but it got me going with good first layers.  As I got better and more consistent at bed leveling, I gradually dropped it back down and now it's at 100% with the rest of the layers.  A washed build surface, wiped down with alcohol, hairspray for adhesion, and a piece of parchment paper to level is what works for me.  Every machine and every person is at least a little different, you just need to find that one thing that works for you.

  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high
    On 12/29/2020 at 11:15 AM, kickasskingy said:

    I can confirm that this bug is still present in the latest version of Cura. The piece of paper levelling system is irrelevant as the Cura generated G-code appears to fail to reset Z to 0 after the nozzle cleaning lines. The only work around I have for this so far, is to quickly reset the Z offset on the printer at the start of each print. 

     

    Is this still a thing?  I've definitely noticed Cura doesn't honour the hardware Z offset once, say, a purge line has been printed via Start gcode.  If I remove the whole Start gcode, the hardware Z offset is honoured; re-add the purge line Start gcode and the rest of the print starts noticeably higher (I compare a rough non-Start gcode calibration pattern with a rough calibration pattern with Start gcode, and the former pattern is clearly rougher because of the lower Z height).

     

    Is there a fix that can be applied to the end of the Start gcode to overcome this oddity?

  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    I have this issue going on now. I can copy and paste the same g code from Cura to the Creality slicer, and it prints fine. only in Cura do I have an issue... I am stumped. I tried the z code offset, and so far the results are better, but still not correct... Im still playing with it, but it Definatly has a strange issue.

  • Link to post
    Share on other sites

    Posted (edited) · First layer of file from Cura is printing too high

    Using Cura 5.2.1 with Ender3v2 running Mirscoc Firmware.

    So I was having this same issue. 

    I noticed I had to lower my z offset after the purge,  sometimes after the skirt, usually around -0.2mm so if my Probe Z-offset was -1.00mm I would need to lower it to -1.20mm on every new print.

    Inside the Gcode I found the only place that altered Z by that amount was

    G0 F**** X**.*** Y**.*** Z0.2

    So I added a post script in cura to search and replace Z0.2 with Z0 and it worked changing the values automatically, however I edited the code and implemented the changes outside of Cura to get the print to work. And the model was initially sliced without adding in supports in Cura. Using supports might alter the effectiveness of this fix as I just tried slicing my model with supports and it doesn't seem to be working. I had to actually raise my Z... so I might need some more tweaking. I disabled tilt mesh as the new meshs it spits out has a ring of values around the perimiter that aren't even close to the inner values. It's guessing is way off and rebuilding and auto mesh returns the same values I already had, so the bed hasn't gone out of alignment.

    Edited by Hyaleah
  • Link to post
    Share on other sites

    Posted (edited) · First layer of file from Cura is printing too high
    On 2/15/2022 at 11:43 AM, EckyThump said:

    Is there a fix that can be applied to the end of the Start gcode to overcome this oddity?

     

    Possibly. I'm looking into post scripts in cura that will automatically search out and replace a certain z value. However it's not been a 100% success rate.

    Edited by Hyaleah
  • Link to post
    Share on other sites

    Posted (edited) · First layer of file from Cura is printing too high

    No matter how you do it - if you level the bed and the initial "Z gap" is exactly "0" then the line G1 F1000 X0 Y0 Z0.2 would set the nozzle at exactly 0.2 above the build surface.

    For an ABL system the commands are often:

    G28

    G29

    and then either purge lines or printing start.

    The printer is supposed to go where it's told.  If the initial gap is too high (or too low) then there is something going on with the ABL settings and the Z-offset.  The only other real possibility is that there is a problem in the Z system that causes the printer to NOT go where it was told, but that has a very low probability.

     

    Manual leveling is different.  You Auto-Home the printer, level the bed, and then start the print.  Almost every printer definition file puts a "G28" in the StartUp gcode.  What that does is to reset the Z=0 location.  Considering the quality of parts on my printer, I found that the Z=0 was often a different height than the Z=0 of my first Auto-Home.  That changed the height of my first layer.  The bed didn't move, the nozzle height was changed by a Z-stop switch that isn't very "repeatable".

    Changing my Startup Gcode to "G28 X Y" solved the problem.  The "Z" location I leveled with is the "Z" location I print with.

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    It used to be a recursive error. 1st print I would set the z-offset to -1.11, prints fine, second print I set it to -1.31, third print I set it to -1.51, fourth  -1.71, and so on. Each successive print deviates +0.2 from the last. Requiring me to lower it.

    Lately however that went away and now it's just +0.2 somewhere after the purge but before the actual mesh starts printing.

    I was wondering why they use G0 instead of G1. I can always append a G0 Z or G1 Z just before the mesh.

     

    I thought about the other fixes where they don't use Cura or simply remove the start Gcode. Though I need mine to at least activate my mesh.

  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high

    The convention is to use G0 for moves with no extrusion and to use G1 if there is an extrusion.  The oddity in Cura is when Z-hops are enabled.  It may be because Z-hops are related to retractions/primes and so a Z hop move will be with a G1 even though there is no E value in the line.

     

    "Lately however that went away and now it's just +0.2"

    I think it's a firmware issue.  A line like "G0 Fxxxx Xxxx Yxxx Z0.2 should send the print head to Z=0.2.

    IF there is some sort of compensation for the bed leveling written into the firmware, then the firmware may be adjusting that, but the command states to "travel to Z=0.2".

     

    G29 has some parameters that can be applied.  Which parameters is likely dependent on your firmware.  The same would be true for M420.  The Marlin definitions are HERE and the RepRap definitions are HERE.

     

    When you use Search and Replace to make changes it has the option to "Use Regular Expressions".  That option can make the Search very specific.

    Search:  ;LAYER:1\n

    Replace: ;LAYER:1\nG0 X0 Y0 Z0\n

    Use Regular Expressions:  TRUE

    The search criteria with the "\n" newline character would be limited to Layer:1 (rather than Layer:1, Layer:10, Layer:11, Layer:100, etc.)

    Rather than using the G1 line it might be better to use the "G92 Zx.x" line to set the Z position for the file.  That way every Z value in the file would be adjusted.  A third possibility would be to use M206 and adjust the home offset Z.

     

    • Like 1
    Link to post
    Share on other sites

    Posted (edited) · First layer of file from Cura is printing too high

    I just disable "HS mode" in MRISCOC firmware. Whatever it does, there was a note to disable it when using the CR Touch with Meshes denser than 5x5.

     

    Second I copied over the start and end Gcode from Creality Slicer over to Cura. Adding in G29 L0 and G29 A. So far two consecutive prints without issue.

    I was so close to giving up and just installing Crealities CR touch Firmware. 

    Edited by Hyaleah
  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high
    On 8/30/2020 at 3:11 PM, hakim46 said:

    I was having the pretty much the exact same issue, Ender 3 - Cura 4.7. My initial layer height was set to .2mm, what ended up working for me was installing the z offset plugin from the cura marketplace, setting that to -0.1 and setting initial flow to %115. Gave me a good first layer with solid adhesion, didn't have to mess with the gcode or anything else. 

    Yes. This right here. I was going crazy trying to figure out why, as soon as I updated my Cura, non of my layers were sticking.

  • Link to post
    Share on other sites

    Posted · First layer of file from Cura is printing too high
    On 11/11/2023 at 9:13 PM, amvamv said:

    Yes. This right here. I was going crazy trying to figure out why, as soon as I updated my Cura, non of my layers were sticking.

    Update: I'm using -0.2 as an offset now. Leveled with a card stock (thicker than standard letter) piece of paper.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...