Jump to content

Feature Request - Don't print over blank space for z seam alignment


stardude900

Recommended Posts

Posted · Feature Request - Don't print over blank space for z seam alignment

So the title might need a little bit more explanation, but here is an issue I've run into sometimes when printing through CURA.

 

In my Z seam alignment settings, I generally try to use "sharpest corner" in order to have it not try to print at curves right at the start of a new layer (in the x / y direction).  This usually works out okay, but since I am printing with a 0.8mm nozzle, sometimes on arches or curves in the z direction, it will decide to start the layer over blank space (like seen below).  When I change the Z seam alignment to be something like "back left corner" or "front right corner", it will only print over existing material for one half of this model and not the whole thing.  So one side *generally* is okay since, while yes it's printing over empty space, it came from already existing layers and has something to hold on to. 

 

So I guess the hope would be a sub-setting or something for Z seam where you can say "start layer over existing material" or "max overhang angle for start of new layer".  Hope that makes sense.

 

And yes, I understand that not everyone prints with larger nozzles and that this could be fixed by better model design, but I'm also not the best at designing things and it stinks having to go back and tweak this for hours when only half of a few layers get messed up from this.

 

Also not sure if feature requests are supposed to be here or over on the github, but I guess I can copy / paste over there if needed.

 

image.thumb.png.0600b0ae1ef9bde1fab902a36177c706.png

  • Link to post
    Share on other sites

    Posted · Feature Request - Don't print over blank space for z seam alignment

    If Cura 4.6 has the overhanging wall angle setting, try reducing that so that it detects the overhangs and then it should move the z-seam to avoid the overhung areas.

    • Thanks 1
    Link to post
    Share on other sites

    • 9 months later...
    Posted · Feature Request - Don't print over blank space for z seam alignment
    On 7/23/2020 at 7:20 AM, burtoogle said:

    If Cura 4.6 has the overhanging wall angle setting, try reducing that so that it detects the overhangs and then it should move the z-seam to avoid the overhung areas.

    I just came here to say this is the correct answer for anyone looking for solution for seam alignment at overhangs. In Cura 4.9.0 the parameter is under Experimental tab and is called Overhanging Wall Angle with default value set to 90°.

    90°:
    obraz.thumb.png.d27ebde0c399208da696bd2b3b036826.png

     

    20°:

    obraz.thumb.png.7ae31bb8555afcd92e2322e084625b8a.png

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...