Jump to content
Ultimaker Community of 3D Printing Experts

Disable waiting codes and retraction (Cura 4.7)


mbr3m3r
 Share

Recommended Posts

Posted (edited) · Disable waiting codes and retraction (Cura 4.7)

Hi, I need to disable the waiting codes (M109, M190 and M105) and the -1.0 retraction at the beginning of each print.

 

 

I tried modifying the JSON (fdmprinter.def.json located in C:\Program Files\Ultimaker Cura 4.7\resources\i18n) like:

 

#: fdmprinter.def.json
msgctxt "material_bed_temp_wait label": { "default_value": false },
msgid "Wait for Build Plate Heatup"
msgstr ""

#: fdmprinter.def.json
msgctxt "material_bed_temp_wait description": { "default_value": false },
msgid ""
"Whether to insert a command to wait until the build plate temperature is "
"reached at the start."
msgstr ""

#: fdmprinter.def.json
msgctxt "material_print_temp_wait label": { "default_value": false },
msgid "Wait for Nozzle Heatup"
msgstr ""

#: fdmprinter.def.json
msgctxt "material_print_temp_wait description": { "default_value": false },
msgid "Whether to wait until the nozzle temperature is reached at the start."
msgstr ""

 

And the JSON from my specific printer (robo_3d_r1.def.json located in C:\Program Files\Ultimaker Cura 4.7\resources\definitions) like:

 

 

{
    "name": "Robo 3D R1",
    "version": 2,
    "inherits": "fdmprinter",
    "metadata": {
        "visible": true,
        "author": "Ultimaker",
        "manufacturer": "Robo 3D",
        "file_formats": "text/x-gcode",
        "platform_offset": [ 0, 0, 0],
        "machine_extruder_trains":
        {
            "0": "robo_3d_r1_extruder_0"
        }
    },

    "overrides": {
    "material_print_temp_wait": {
        "default_value": false
    },

        "machine_start_gcode": {
            "default_value": " "
        },
    "material_bed_temp_wait": { 
        "default_value": false 
        },

        "machine_end_gcode": {
            "default_value": " M104 S0                     ;extruder heater off\n M140 S0                     ;heated bed heater off (if you have it)\n G91                                    ;retract the filament a bit before lifting the nozzle, to release some of the pressure\n ;move Z up a bit and retract filament even more\n G28 X0 Y0                              ;move X/Y to min endstops, so the head is out of the way\n M84                         ;steppers off\n G90                         ;absolute positioning\n"
        },
    "material_print_temp_wait": { "default": false },
        "cool_min_layer_time": { "default_value": 7 },
        "retraction_speed": { "default_value": 50 },
        "cool_min_speed": { "default_value": 19 },
        "support_angle": { "default_value": 50 },
        "prime_tower_size": { "default_value": 8.660254037844387 },
        "support_enable": { "default_value": true },
        "raft_airgap": { "default_value": 0.2 },
        "layer_height_0": { "default_value": 0.15 },
        "material_flow": { "default_value": 100 },
        "infill_sparse_density": { "default_value": 10 },
        "wall_thickness": { "value": "1.2" },
        "retraction_amount": { "default_value": 3 },
        "layer_height": { "default_value": 0.2 },
        "speed_print": { "default_value": 40 },
        "machine_extruder_count": { "default_value": 1 },
        "retraction_combing": { "default_value": "off" },
        "machine_heated_bed": { "default_value": true },
        "machine_center_is_zero": { "default_value": false },
        "machine_height": { "default_value": 210 },
        "adhesion_type": { "default_value": "raft" },
        "machine_gcode_flavor": { "default_value": "RepRap (Marlin/Sprinter)" },
        "machine_depth": { "default_value": 245 },
        "machine_width": { "default_value": 225 },
        "support_z_distance": { "default_value": 0.22 },
        "machine_name": { "default_value": "ROBO 3D R1" }
    }
}
 

 

This deactivated the waiting code for the bed but I'm still getting the waiting codes for the hotend like:

 

;FLAVOR:Marlin
;TIME:4940
;Filament used: 8.64955m
;Layer height: 0.3
;MINX:57.311
;MINY:74.813
;MINZ:0.2
;MAXX:152.688
;MAXY:170.188
;MAXZ:8.3
;ZOFFSETPROCESSED
;Generated with Cura_SteamEngine 4.7.0
M140 S80
M104 S205
M105
M109 S205

M82 ;absolute extrusion mode
G28 X0 Y0
G28 Z0
G29
G92 E0
G92 E0
G1 F3000 E-1
;LAYER_COUNT:28
;LAYER:0

 

Any ideas why isn't this modifications on the JSON file working?

 

EDIT: I was able to get rid of the waiting codes setting up the temperatures on the gcode header, but I have no idea where to start or how to get rid of the "G1 F3000 E-1" at the header. 

 

 

Edited by mbr3m3r
  • Link to post
    Share on other sites

    Posted · Disable waiting codes and retraction (Cura 4.7)

    The problem with the retraction line is that if you change the setting for Retraction Distance or Retraction Speed in Cura, then the line changes.  I use the Search and Replace plugin to change that line to "G92 E-1" and I get nice starts to my skirt/brim.  If the search criteria doesn't match the current Distance / Speed settings the plugin can't find the line to change it.  I tend not to change the Distance or Speed very often so Search and Replace works for me.

    • Like 1
    Link to post
    Share on other sites

    Posted · Disable waiting codes and retraction (Cura 4.7)

    Thanks! Yeah that "Search and replace" plugin works great!

     

    I'm just curious why didn't the mods in the JSON file apply for the hotend. But all good now.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...