Jump to content

Extruder 2 doesn't like some specific models


Recommended Posts

Posted · Extruder 2 doesn't like some specific models

With some 2-part models, I can bring in both .stl files, assign one to Extruder 1 and the other to Extruder 2, merge, and slice and print.  No problem.


With other 2-part models, I can bring in both .stl files and assign one to Extruder 1, but the when I assign the other to Extruder 2, immediately one of the models gets "hatched out".

  • A specific one of the models doesn't like Extruder 2 in use, and it will "hatch out" regardless of which model I assign to Extruder 2.
  • Cura immediately objects to this model when extruder 2 is used, regardless of which model is assigned to which extruder.
  • If I just bring in this model by itself and assign to extruder 2, it Cura also objects. 
  • I have the two extruders configured identically except for a very minor change in the extruder switching code. (One should heat up and the other one cool down when I make the switch, so the switching codes are symmetric rather than identical.)


Does anyone have an idea what might be wrong here?

Is there an error log or someplace else where I can get more information about what Cura is objecting to?

I am attaching both .stl files for reference.  My intention is to print the "Base" file with extruder 1 and the "Letters" file with extruder 2.


Thanks in advance,

-- mike

Base_Embossed_V15.stl Letters_Embossed_V15.stl

  • Link to post
    Share on other sites

    Posted · Extruder 2 doesn't like some specific models

    I can't really reproduce the issue. I've done the following

    1. Load both files

    2. Select both of the objects

    3. RIght mouse -> merge models
    4. Ctrl + click on the letters to select it

    5. Select second extruder for the letters



  • Link to post
    Share on other sites

    Posted · Extruder 2 doesn't like some specific models

    Many thanks for taking a look at my problem.  I'm sorry that you were unable to reproduce the issue.  That always makes things so much harder. (I have 35 years experience as a software developer.)  Since you did things in a slightly different order than I had, I tried following your procedure exactly to see if that would solve the issue.  Unfortunately, no.


    I was not aware that you can still select the two models separately after merging them.  So I had tried to set extruder 2 before merging the models, and you did it after merging the models.  Now I have learned that you can still access the two models separately even after the merge, so I tried it that way.  I still get the error when I select Extruder 2 for the "Base" model.


    One thing I try to do when debugging an issue like this is try to come up with a simpler scenario where the same thing will go wrong,  I now find that bringing the "Letters" file is not necessary for demonstrating the problem.  All I have to do is bring in the "Base" file, and then set Extruder 2, and the model immediately gets "hashed out".  As that requires fewer steps and will interface with Cura in fewer places, I suggest we continue looking at this problem using the simpler example.


    For the record, I am using Cura version 4.7.1.  I first made sure that I have both extruders enabled and set to valid materials. I simply brought in the "Base" model (which is automatically selected).  Then I right-clicked and checked the box for Extruder 2.  The error appeared.  For good measure, I hit "Slice" so that I could see what Cura would say about the error.  Please see the screen shots below.  Also, you should know that I only recently built up my printer with the E3D Chimera and started trying to use dual extrusion printing.  I am a moderately experienced Cura user with single extruder printers. I have succeeded with dual extrusion on a couple of other models.  Still, I am new to dual extrusion, and may be making some stupid mistake. 


    I wonder if there is a way to get Cura to tell us what it is objecting to?  Is there a logfile I can read or forward to you?  Is there some option for turning on additional debugging?


    best regards,

    -- mike






    Clicked on Extruder2.jpg

  • Link to post
    Share on other sites

    Posted (edited) · Extruder 2 doesn't like some specific models


    Based off of your most recent pictures it looks like you have a "Prime Tower" touching your model. It prints in the circled area. You can change the X and y position of this so it doesn't touch your model and that should fix it.



    Edited by Tomahawk_101
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...