Jump to content
Ultimaker Community of 3D Printing Experts

Cura layer count starting number in 'Preview' is different than in G-code


3d_model_guy
 Share

Recommended Posts

Posted · Cura layer count starting number in 'Preview' is different than in G-code

I am using Cura 4.7.

The starting layer count in 'Preview' starts at 1, where the actual G-code starts at 0.

This creates a problem when using 'Post Processing Scripts' such as ChangeAtZ with layer no. as trigger.

 

Is there a way to change either preview layer counts or the G-code counts to start at the same number?

  • Link to post
    Share on other sites

    Posted · Cura layer count starting number in 'Preview' is different than in G-code

    No.  A post processor plugin was tried but there were side effects.  Cura layers are base 1 and gcode layers are base 0.  I have about 10 slicers.  The only one I know of that starts gcode at 1 is Simplify3d.

     

     

     

     

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...