Jump to content

wrong extruder used for the first layer


0xBeFa

Recommended Posts

Posted · wrong extruder used for the first layer

I am using a Qidi Tech 1 dual extruder printer with a custom profile made for the Flashforge Creator Pro (which seems to be exactly the same printer).

 

I noticed that for the first layer sometimes the wrong extruder is used. So if Cura starts on the first layer with the support material (which I set to the right extruder) the printer pushes filament trough the left nozzle which is set to the standby temperature. The right nozzle is heating correctly but not extruding. For subsequent layers the extruder switch is working as expected.

 

My start G-code ends with following lines:

G92 A0 B0 ; zero extruders
M135 T{initial_extruder_nr} ; left or right tool
M73 P1 ;@body (notify GPX body has started)
; **** end of start.gcode ****

 

Apparently the variable {initial_extruder_nr} is not set correctly.

 

At the moment I'm applying a workaround where I looking at the first layer after slicing and if it starts with the right extruder I use the search and replace post processing plugin to manipulate the G-code:

Search: M135 T1 ; left or right tool

Replace: M135 T0 ; left or right tool

 

Is this a bug in Cura or is there something wrong with the printer profile?

  • Link to post
    Share on other sites

    Posted · wrong extruder used for the first layer

    "Is this a bug in Cura or is there something wrong with the printer profile?" 

    That's always the question.

    The printer profiles are developed by third parties and submitted to Ultimaker for inclusion in Cura.  I'm more of a Marlin guy - but explicitly setting the extruder for the skirt/brim seems to work at setting "initial_extruder_nr" correctly.  When the gcode flavor is set to "Makerbot" I still get a "T#" at the start of a gcode file even with the M135 line first in the Start-Up gcode.

    With no build plate adhesion and the part set to Extruder 1, the gcode file appears to incorrectly start with Extruder 0.

    T1
    M82 ;absolute extrusion mode
    M135 T0

    But with a skirt set to Extruder 1, the gcode starts correctly

    T1
    M82 ;absolute extrusion mode
    M135 T1

    You might want to play with that a bit and maybe search GitHub to see if the behavior has been noted before.  There is a form on GitHub available for filling out bug reports, and this appears to qualify.  Be sure to mention that the printer has Makerbot firmware as the problem doesn't seem to occur with Marlin.

  • Link to post
    Share on other sites

    Posted · wrong extruder used for the first layer

    In the machine settings I have set the G-code flavor set to RepRap. I don't really know what the difference between Marlin, RepRap or Makerbot is. My printer has Sailfish firmware.

     

    I'm also confused about the start g-code.  In the machine settings dialog there is one field for start g-code and under print settings I have enabled the "code for single extrusion" and "code for dual extrusion" fields.

    The print setting fields contain different start routines for single or dual but they are not used. Instead the start code from the machine settings is used which is dual start code.

     

    Where is the correct place to edit the start g-code?

  • Link to post
    Share on other sites

    Posted · wrong extruder used for the first layer

    The firmware flavor is important as the different flavors may have commands that only they use.  I believe your gcode flavor should be set to Makerbot.  You need to check the QIDI site to make sure.

     

    As to which Start-Gcode applies:  The regular Start-Up gcode lines get entered at the beginning of the Gcode file.  The extruder gcode lines get inserted every time that extruder gets activated.  That makes them extruder specific.  You can test by entering these for the appropriate extruder and then creating a gcode file that uses both extruders.  Open the gcode in Notepad and then search for M117.  It should be in there multiple times.

     

    ;Start Extruder 1

    M117 Ext 1

    ;End Ext 1

     

    ;Start Extruder 2

    M117 Ext 2

    ;End Ext 2

  • Link to post
    Share on other sites

    Posted · wrong extruder used for the first layer

    Ok I will make some tests with Makerbot flavor.

     

    The extruder G-code is clear to me, I was talking about these settings under the experimental section:
    559152536_2021-02-0718_03_14-Window.thumb.png.08f22524f7260dc173564c352ed60592.png

  • Link to post
    Share on other sites

    Posted · wrong extruder used for the first layer

    I've never seen those before.  For support you will have to go to QIDI or maybe Flashforge.

  • Link to post
    Share on other sites

    Posted · wrong extruder used for the first layer

    I've hit the same issue with a different printer. After a bit of digging it seems that there actually is something buggy in setting initial_extruder_nr in the case that there are no adhesion structures selected: https://github.com/Ultimaker/Cura/issues/15673

    It's a pretty unique case and the workaround I have found for now is to simply enable a skirt. Then the correct extruder is selected AND you get some nice pre-extrusion ;)

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...