Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

RepRap not responding to RTS reset. Failed to connect

Recommended Posts

Hey everyone,

I have built my Ultimaker a couple of weeks ago, but had problems installing it on my Win7 computer. Today I have tried my XP laptop and I am having exactly the same problems...

ReplicatorG says this error message:

"RepRap not responding to RTS reset. Failed to connect"

I have also installed Netfabb and I am not being able to connect there either.

What its doing that I think is normal behavior is that the printer head lights up in blue.

The fan runs slowly when usb connected and ramps up when main power switch is on.

I have 2 green leds on the extra board.

I have an orange light that is flashing on the arduino board.

I can see that the arduino is installed in the Device manager and runs on COM13.

What I have been doing is reading about the problem and playing around with the baud rates. But I cant get anything to work. In the Device manager, arduino board settings I can change the baud that was originally set to 9600. I changed it in the Ultimaker.xml in ReplicatorG to have the same value. Nothing happend. I tried to change both to 57600 without luck.

Right now I am feeling really stuck and hope that you guys have some ideas on what to do? Is it possible to update the code in the arduino for instance?

Any help is appreciated.

Share this post

Link to post
Share on other sites

Yes. It's possible to update the Arduino code. There is a firmware upgrade option in the RepG menu (even works if you cannot connect properly)

Another possibility would be SkeinPyPy-Beta4:


This will upgrade your firmware to Marlin V1 (which is a lot newer then what's shipped with RepG) on 250000 baud. The disadvantage is that it won't work with RepG anymore then (because RepG cannot handle 250000), but the good thing is that you don't need RepG with SkeinPyPy.

The fan rotating slowly, and later fast if you turn the machine on is normal. If the slow rotating fan bothers you, you can remove the "ARDN_PWR" header from the board. It's intended use is to power the Arduino from the mains power. However, a side-effect is that the USB powers then FAN then when the power is off.

Share this post

Link to post
Share on other sites

The arduino runs at the following baud rates:

9600 for firmware updates (I think, not sure)

57600 for 5D firmware (stock)

115200 for Marlin/Sprinter (build3 in repG works best)

250000 for Marlin V1+ (does not work with repG 26)

Just check if you have the correct baud rates. Do NOT alter the baud rate in the system settings.

Share this post

Link to post
Share on other sites

@Daid: Thanks for the fan suggestion. It was so irritating to always have to have the fan on.

@mr_seeker: Thanks. Now I know which baud values to try.

Woho...... Thanks Daid. I went in to replicatorg Machine/update firmware and chose the standard one from the list. Now Replicatorg showes its connected :-D I also changed the replicatorg/machine/ultimaker.xml and changed the 9600 to 57600. Nice. I think that the Netfabb is working now aswell after I canged it to 57600 baud.

Thanks for the help. Now I have to figure out whats to do next to be able to get a test print :D

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!