Jump to content
UltiMaker Community of 3D Printing Experts

Initial layer temperature not set in 4.11? (SOLVED)


Recommended Posts

Posted · Initial layer temperature not set in 4.11? (SOLVED)

Hi All,

Upgraded to 4.11 yesterday and for a difficult print I set the initial layer temperature to a rather higher level than the remaining layers (215°C vs 201°C).

However the print still didn't work and after some further investigation in the GCode, I cannot see that the initial temperature has been set - the standard printing temperature is set at the start and is never changed.


Happy to be told that I have not correctly set something up....


snip from the Gcode (temperature set is highlighted in RED😞

T1 ;switch to other head
M109 S201.0 ; Wait for the temp to hit 200
G00 X125 Y-60 Z0.2 ;
G00 Z0
G92 E0 ;
G01 E25 F100 ; Extrude a little bit to replace oozage from auto levelling
G01 X100 Y-50 F100 ;
G01 Z5 ;

M109 S201.0
M82 ;absolute extrusion mode
;Deltacomb Extruder 2
;Put your custom code here
M83 ;relative extrusion mode
M83 ;relative extrusion mode
G1 F2400 E-3.5
M204 T2250
M566 X600 Y600
G1 F10200 Z1.3
G0 F7140 X5.943 Y2.519 Z1.3
M204 P1000
M566 X1500 Y1500
G1 F10200 Z0.3


and down at the start of layer #1:

M106 S127.5
M204 P1333
M566 X1500 Y1500
;MESH:Part Studio 1 - Part 1a.stl
G1 F3360 X2.206 Y-0.014 E0.13276


and a snip from the settings:





  • Link to post
    Share on other sites

    Posted · Initial layer temperature not set in 4.11? (SOLVED)
    54 minutes ago, nallath said:

    That's because your start-gocde probably sets the printing temperature and not the initial printing temperature.

    Well there is a set print temperature to 200 because I do a preload of the nozzle and squirt a few mm off bed after bed levelling and before running the main code.

    But why should an initial M109 prevent the initial layer temperature from being set?

  • Link to post
    Share on other sites

    Posted · Initial layer temperature not set in 4.11? (SOLVED)

    Because you use the {material_print_temperature} instead of {initial_material_print_temperature} replacement tag in the g-code (or well, that's what I think is going wrong)


  • Link to post
    Share on other sites

    Posted · Initial layer temperature not set in 4.11? (SOLVED)
    7 minutes ago, nallath said:

    Because you use the {material_print_temperature} instead of {initial_material_print_temperature} replacement tag in the g-code (or well, that's what I think is going wrong)


    Thank you very much - exactly the problem, well solved from a distance.


    Not a bug, just the operator (again!)


    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.3 stable released
        In this stable release, Cura 5.3 achieves yet another huge leap forward in 3D printing thanks to material interlocking! As well as introducing an expanded recommended print settings menu and lots of print quality improvements. Not to mention, a whole bunch of new printer profiles for non-UltiMaker printers!
          • Thanks
          • Like
        • 21 replies
      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 18 replies
      • UltiMaker Cura Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 22 replies
    • Create New...